dev-python/catkin_pkg: eapi update, bump to 0.4.8
authorAlexis Ballier <aballier@gentoo.org>
Fri, 17 Aug 2018 12:57:47 +0000 (14:57 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 17 Aug 2018 13:07:58 +0000 (15:07 +0200)
Package-Manager: Portage-2.3.46, Repoman-2.3.10

dev-python/catkin_pkg/Manifest
dev-python/catkin_pkg/catkin_pkg-0.4.8.ebuild [new file with mode: 0644]
dev-python/catkin_pkg/catkin_pkg-9999.ebuild

index bcf225a1d04c3f27f3f2562e5dddcb8aa5e9678c..2d3c4c53dcaa1860bbf9b5ae06c4f1217586d8c9 100644 (file)
@@ -1 +1,2 @@
 DIST catkin_pkg-0.4.7-gh.tar.gz 60765 BLAKE2B 905de7f4f013f8e7d6472b5159cb0e9ac82bb06dfca0308a7a5f8881402a721d987a016f7980f7a435a7122c4771311f82f56f460949370ecd93057ef8a8bb25 SHA512 1e947c09aa4789d414de74bed7b1aa3d5f5d16d22a8a4609f656b47e51b7318fdd21e003f8bf65355728abaf54a016ce2d78b79cc4ab8bd7c3e048b66c0c0f6e
+DIST catkin_pkg-0.4.8-gh.tar.gz 60811 BLAKE2B f7bcdb121844837701e203bfefd3ad9b454362d0d9f5b912a1df542dbb50ea402f1556b4f4031afa13dfdeb852f955d175f80344b773fa959fecf522ceb06fb6 SHA512 b697d177164d681e94f19f7f0ec768cb91ba5bf31cd3dfd41a24bc3347957b30f97bf1cc3e3fadb7c3c4f48a5d0306835a9496a9e4ab7b36784f7bbaf4268b6a
diff --git a/dev-python/catkin_pkg/catkin_pkg-0.4.8.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.4.8.ebuild
new file mode 100644 (file)
index 0000000..f4dc76b
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+       SCM="git-r3"
+       EGIT_REPO_URI="https://github.com/ros-infrastructure/catkin_pkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the catkin package system"
+HOMEPAGE="http://wiki.ros.org/catkin_pkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+       SRC_URI=""
+       KEYWORDS=""
+else
+       SRC_URI="https://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
+       KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/docutils[${PYTHON_USEDEP}]
+       dev-python/python-dateutil[${PYTHON_USEDEP}]
+       dev-python/pyparsing[${PYTHON_USEDEP}]
+"
+BDEPEND="
+       test? (
+               dev-python/nose[${PYTHON_USEDEP}]
+       )
+"
+DEPEND="${RDEPEND} ${BDEPEND}
+       test? (
+               dev-python/flake8[${PYTHON_USEDEP}]
+               dev-python/mock[${PYTHON_USEDEP}]
+       )"
+RDEPEND="${RDEPEND}
+       !<dev-util/catkin-0.7.14"
+PATCHES=(
+       "${FILESDIR}/catkin_prefix2.patch"
+       "${FILESDIR}/argparse.patch"
+       "${FILESDIR}/ros_packages.patch"
+       "${FILESDIR}/infinite_loop3.patch"
+)
+
+python_test() {
+       nosetests -s --tests test || die
+}
index 46f2913d41f11b0e7bb89c95cf40ed0d4f3fd591..f4dc76b3fa344dea5027a3e643df51b2cf808337 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
 
 SCM=""
@@ -32,13 +32,16 @@ RDEPEND="
        dev-python/python-dateutil[${PYTHON_USEDEP}]
        dev-python/pyparsing[${PYTHON_USEDEP}]
 "
-DEPEND="${RDEPEND}
+BDEPEND="
        test? (
-               dev-python/mock[${PYTHON_USEDEP}]
                dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/flake8[${PYTHON_USEDEP}]
        )
 "
+DEPEND="${RDEPEND} ${BDEPEND}
+       test? (
+               dev-python/flake8[${PYTHON_USEDEP}]
+               dev-python/mock[${PYTHON_USEDEP}]
+       )"
 RDEPEND="${RDEPEND}
        !<dev-util/catkin-0.7.14"
 PATCHES=(