dev-ml/async_ssl: add 0.9.1
authorHans de Graaff <graaff@gentoo.org>
Mon, 15 Jul 2019 07:03:33 +0000 (09:03 +0200)
committerHans de Graaff <graaff@gentoo.org>
Mon, 15 Jul 2019 07:03:50 +0000 (09:03 +0200)
Fixes: https://bugs.gentoo.org/675502
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

dev-ml/async_ssl/Manifest
dev-ml/async_ssl/async_ssl-0.9.1.ebuild [new file with mode: 0644]

index 094bce3f7e5d9f8b75de538c3daf12df310b099e..24567712360bb8a94ca05b42cc55349c852afe0d 100644 (file)
@@ -1 +1,2 @@
 DIST async_ssl-0.9.0.tar.gz 28227 BLAKE2B e916e196964d085312836d773e290ac52c950c5ceb084347557d72776c7b6b9548ad2bd01c5fc6fa701d18c55fff62e48af5459bf5897478252f8d27dd6687fc SHA512 bb023e0c60f9f04368f2e2a4aea80700a60853a03fe1550fe48a9defe42ec66736a6cc0cf40c6a472cd3f8b5b30d79711e4fd714b53ebd4ba7f3f3c22eb7a15e
+DIST async_ssl-0.9.1.tar.gz 28162 BLAKE2B 74987fcad26dcb641687e044ef76531cfa88e2bb62524d0eddf5ce3fe4f4dc9c7b07f13de63e9cdddd4a5db2e7e20f2a7f3a8543b17678a342e2890ed816189a SHA512 5e20d3c2a46e81d725076a80347047de90d00d6a0956457656ffd629d80b7a65958fd8a831d407dd11e3a3583662ed1e04242e71580ab7e982dc579ee69bface
diff --git a/dev-ml/async_ssl/async_ssl-0.9.1.ebuild b/dev-ml/async_ssl/async_ssl-0.9.1.ebuild
new file mode 100644 (file)
index 0000000..aece7ea
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="An Async-pipe-based interface with OpenSSL."
+HOMEPAGE="https://github.com/janestreet/async_ssl"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+       dev-lang/ocaml:=
+       dev-ml/async:=
+       dev-ml/base:=
+       dev-ml/configurator:=
+       dev-ml/core:=
+       dev-ml/ppx_driver:=
+       dev-ml/ppx_jane:=
+       dev-ml/stdio:=
+       dev-ml/ocaml-ctypes:=
+       dev-libs/openssl:0=
+       dev-ml/ocaml-migrate-parsetree:=
+"
+DEPEND="${RDEPEND}
+       dev-ml/opam
+       dev-ml/jbuilder
+"
+
+src_install() {
+       opam-installer -i \
+               --prefix="${ED}/usr" \
+               --libdir="${D}/$(ocamlc -where)" \
+               --docdir="${ED}/usr/share/doc/${PF}" \
+               ${PN}.install || die
+}