new upstream release.
authorAkinori Hattori <hattya@gentoo.org>
Sun, 24 Dec 2006 14:47:04 +0000 (14:47 +0000)
committerAkinori Hattori <hattya@gentoo.org>
Sun, 24 Dec 2006 14:47:04 +0000 (14:47 +0000)
Package-Manager: portage-2.1.1-r2

app-i18n/anthy-ss/ChangeLog
app-i18n/anthy-ss/anthy-ss-8419.ebuild [new file with mode: 0644]
app-i18n/anthy-ss/files/digest-anthy-ss-8419 [new file with mode: 0644]

index b8b7cd702afbf71a3805daa350688770e4791ba0..2a16fb221848ffa2bcd2e369fd6e5f5924a6c1a2 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for app-i18n/anthy-ss
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.93 2006/12/13 11:53:42 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/ChangeLog,v 1.94 2006/12/24 14:47:04 hattya Exp $
+
+*anthy-ss-8419 (24 Dec 2006)
+
+  24 Dec 2006; Akinori Hattori <hattya@gentoo.org> -anthy-ss-8409.ebuild,
+  +anthy-ss-8419.ebuild:
+  new upstream release.
 
 *anthy-ss-8409 (13 Dec 2006)
 
diff --git a/app-i18n/anthy-ss/anthy-ss-8419.ebuild b/app-i18n/anthy-ss/anthy-ss-8419.ebuild
new file mode 100644 (file)
index 0000000..fd54715
--- /dev/null
@@ -0,0 +1,74 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/anthy-ss-8419.ebuild,v 1.1 2006/12/24 14:47:04 hattya Exp $
+
+inherit elisp-common eutils
+
+IUSE="emacs ucs4"
+
+MY_P=${P/-ss/}
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/23182/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+SLOT="0"
+S=${WORKDIR}/${MY_P}
+
+DEPEND="!app-i18n/anthy
+       emacs? ( virtual/emacs )"
+
+src_unpack() {
+
+       unpack ${A}
+       cd "${S}"
+
+       local cannadicdir=/var/lib/canna/dic/canna
+
+       if has_version 'app-dicts/canna-2ch'; then
+               einfo "Adding nichan.ctd to anthy.dic."
+               sed -i /placename/a"read ${cannadicdir}/nichan.ctd" \
+                       mkworddic/dict.args.in
+       fi
+
+}
+
+src_compile() {
+
+       local myconf
+
+       use emacs || myconf="EMACS=no"
+       use ucs4 && myconf="${myconf} --enable-ucs4"
+
+       econf ${myconf} || die
+       emake || die
+
+}
+
+src_install() {
+
+       emake DESTDIR="${D}" install || die
+
+       use emacs && elisp-site-file-install "${FILESDIR}"/50anthy-gentoo.el
+
+       dodoc AUTHORS DIARY NEWS README ChangeLog
+
+       docinto doc
+       rm doc/Makefile*
+       dodoc doc/*
+
+}
+
+pkg_postinst() {
+
+       use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+       has_version virtual/emacs && elisp-site-regen
+
+}
diff --git a/app-i18n/anthy-ss/files/digest-anthy-ss-8419 b/app-i18n/anthy-ss/files/digest-anthy-ss-8419
new file mode 100644 (file)
index 0000000..67944ff
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 84d3d436d8fee78a57cffa95768ab488 anthy-8419.tar.gz 3532063
+RMD160 a9e91468052ff99844044a11b6f43a2890098f0e anthy-8419.tar.gz 3532063
+SHA256 277dafe6fbcc2ecdd8dc27a249077bc191b2531e50eafbd3bdf4562ca29afae6 anthy-8419.tar.gz 3532063