dev-libs/voikko-fi: new package
authorJoonas Niilola <juippis@gentoo.org>
Sun, 8 Sep 2019 06:53:43 +0000 (09:53 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 8 Sep 2019 06:53:43 +0000 (09:53 +0300)
- Finnish dictionary for libvoikko based spell checkers (vvfst
  format), dependency of libreoffice-voikko

Package-Manager: Portage-2.3.75, Repoman-2.3.17
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-libs/voikko-fi/Manifest [new file with mode: 0644]
dev-libs/voikko-fi/metadata.xml [new file with mode: 0644]
dev-libs/voikko-fi/voikko-fi-2.3.ebuild [new file with mode: 0644]

diff --git a/dev-libs/voikko-fi/Manifest b/dev-libs/voikko-fi/Manifest
new file mode 100644 (file)
index 0000000..bae52fd
--- /dev/null
@@ -0,0 +1 @@
+DIST voikko-fi-2.3.tar.gz 694602 BLAKE2B 454afaa76be00645b8640f84c2c91ed0b31be5b46c98d31bba0f4967dce27919eee6a6c452941b3878b498c7f913a413a3d143d658bc38da2a07b32d876ac317 SHA512 b3478cbb6aecebcc25e1c4bce0881a657d664c11190a22c1c2c4ca7e7c62b4c4fd5d396718fbadc8c5ab3c9db5d4349d6cd81440a1394cf4c2f77c52ae608018
diff --git a/dev-libs/voikko-fi/metadata.xml b/dev-libs/voikko-fi/metadata.xml
new file mode 100644 (file)
index 0000000..6b0a0fb
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>juippis@gentoo.org</email>
+    <name>Joonas Niilola</name>
+  </maintainer>
+</pkgmetadata>
diff --git a/dev-libs/voikko-fi/voikko-fi-2.3.ebuild b/dev-libs/voikko-fi/voikko-fi-2.3.ebuild
new file mode 100644 (file)
index 0000000..c9b591d
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5..7} )
+
+inherit python-any-r1
+
+DESCRIPTION="Finnish dictionary for libvoikko based spell checkers (vvfst format)"
+HOMEPAGE="https://voikko.puimula.org/"
+SRC_URI="https://www.puimula.org/voikko-sources/${PN}/${P}.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="${PYTHON_DEPS}
+       dev-libs/foma
+       $(python_gen_any_dep '
+               >=dev-libs/libvoikko-4.0[${PYTHON_USEDEP}]
+       ')"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+       emake vvfst
+}
+
+src_install() {
+       emake DESTDIR="${D}/usr/share/voikko/" vvfst-install
+       einstalldocs
+}