dev-python/testfixtures: Remove Python 2
authorMichał Górny <mgorny@gentoo.org>
Sat, 25 Jan 2020 20:41:44 +0000 (21:41 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 25 Jan 2020 20:54:12 +0000 (21:54 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/testfixtures/testfixtures-4.9.1.ebuild
dev-python/testfixtures/testfixtures-6.8.2.ebuild

index 7c2dbd6ada6a6460a82cb8792c4088f9f4dce6d1..60bd10d75f5f9d3873b2d49900f80994a3a32dee 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-PYTHON_COMPAT=( python2_7 python3_6 )
+PYTHON_COMPAT=( python3_6 )
 
 inherit distutils-r1
 
@@ -21,14 +21,12 @@ DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        doc? (
                dev-python/sphinx[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/pkginfo[${PYTHON_USEDEP}]' python2_7 pypy )
        )
        test? (
                dev-python/manuel[${PYTHON_USEDEP}]
                dev-python/nose[${PYTHON_USEDEP}]
                dev-python/nose-cover3[${PYTHON_USEDEP}]
                dev-python/nose_fixes[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
        )"
 
 python_prepare_all() {
index a3b4728a12a9b37327bf96db472709f9f0cf53e9..a827aad44dd29d97f6c5d2538090ca86ace8be3c 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
 
 inherit distutils-r1
 
@@ -21,11 +21,9 @@ DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        doc? (
                dev-python/sphinx[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/pkginfo[${PYTHON_USEDEP}]' python2_7 pypy )
        )
        test? (
                dev-python/django[${PYTHON_USEDEP}]
-               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
                dev-python/pytest[${PYTHON_USEDEP}]
                dev-python/pytest-django[${PYTHON_USEDEP}]
                dev-python/sybil[${PYTHON_USEDEP}]