app-admin/logstash-bin: bump to 5.6.10
authorTomas Mozes <hydrapolic@gmail.com>
Fri, 13 Jul 2018 13:54:02 +0000 (15:54 +0200)
committerMikle Kolyada <zlogene@gentoo.org>
Sun, 15 Jul 2018 16:16:49 +0000 (19:16 +0300)
Package-Manager: Portage-2.3.42, Repoman-2.3.9
Closes: https://github.com/gentoo/gentoo/pull/9214

app-admin/logstash-bin/Manifest
app-admin/logstash-bin/logstash-bin-5.6.10.ebuild [new file with mode: 0644]

index 965c1c65f1dac969c3c4df843a759beb0332ec48..e0c4d688613e65256e1e77d66876df4ae2878887 100644 (file)
@@ -1,2 +1,3 @@
+DIST logstash-5.6.10.tar.gz 104373711 BLAKE2B 759bf003e1799aeaef0a1279b3c7cf5732126ae65e9ca0a3e315cb6f7a1b4e4417fad1fd86328a58be99e04e8053264d873b04cf43cac2b49490bbdc82c8e8b7 SHA512 9ba887da982755efd21b363e9c084660c9b7e6c042e00a8c599f60d6bba5621af7ede43957f6c3d976888f4c13e6ae17cc69afd184f2dcdd41a311972f59a745
 DIST logstash-5.6.9.zip 108563466 BLAKE2B 9225b823ac1f746481b34894c181aedabb0e69eb4242527271240448504f46aa68ba72f63e3752a6a13c3d567bca89df272a09cacc62739a526e3cb24ca90072 SHA512 f5506b2f2bb2da4b2a8d7b199cc328de6625f623b9498f4f2e5505aa8b4082efa207a06d1df8af7b7c21c400268e51d7ae8b9200afdaa191b8e8644e033a9b6b
 DIST logstash-6.2.4.zip 153969993 BLAKE2B 989f631484be14014b8230e09fa049a0e470078fed938f2df55134a27d5f4f2d8670187126d32c4933b77b496a6ed96e12d180922c2c318c67fb3dbeec5a5a3b SHA512 65f6e5accc4441cb930e5c45723edeea54ba034a25680ca34114296af5a2c456d4152f9b38469475e600fce27a27b0d9c1d206039d12f2ec9cfeb02942a5c189
diff --git a/app-admin/logstash-bin/logstash-bin-5.6.10.ebuild b/app-admin/logstash-bin/logstash-bin-5.6.10.ebuild
new file mode 100644 (file)
index 0000000..b52e9f6
--- /dev/null
@@ -0,0 +1,77 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit java-pkg-2 user
+
+MY_PN="${PN%-bin}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tool for managing events and logs"
+HOMEPAGE="https://www.elastic.co/products/logstash"
+SRC_URI="https://artifacts.elastic.co/downloads/${MY_PN}/${MY_P}.tar.gz"
+
+# source: LICENSE.txt and NOTICE.txt
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="strip"
+QA_PREBUILT="opt/logstash/vendor/jruby/lib/jni/*/libjffi*.so"
+
+RDEPEND="virtual/jre:1.8"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+       enewgroup ${MY_PN}
+       enewuser ${MY_PN} -1 -1 /var/lib/${MY_PN} ${MY_PN}
+}
+
+src_install() {
+       keepdir /etc/"${MY_PN}"/{conf.d,patterns,plugins}
+       keepdir "/var/lib/${MY_PN}"
+       keepdir "/var/log/${MY_PN}"
+
+       insinto "/usr/share/${MY_PN}"
+       newins "${FILESDIR}/agent.conf.sample" agent.conf
+
+       rm -v config/startup.options || die
+       insinto /etc/${MY_PN}
+       doins -r config/.
+       rm -rv config data || die
+
+       insinto "/opt/${MY_PN}"
+       doins -r .
+       fperms 0755 "/opt/${MY_PN}/bin/${MY_PN}" "/opt/${MY_PN}/vendor/jruby/bin/jruby" "/opt/${MY_PN}/bin/logstash-plugin"
+
+       newconfd "${FILESDIR}/${MY_PN}.confd-r1" "${MY_PN}"
+       newinitd "${FILESDIR}/${MY_PN}.initd-r1" "${MY_PN}"
+
+       insinto /usr/share/eselect/modules
+       doins "${FILESDIR}"/logstash-plugin.eselect
+}
+
+pkg_postinst() {
+       ewarn "The default pidfile directory has been changed from /run/logstash to /run."
+       ewarn "Please ensure any running logstash processes are shut down cleanly."
+       ewarn
+       ewarn "The default data directory has been moved from /opt/logstash/data to"
+       ewarn "/var/lib/logstash/data. Please check and move its contents as necessary."
+       ewarn
+       ewarn "Self installed plugins are removed during Logstash upgrades (Bug #622602)"
+       ewarn "Install the plugins via eselect module that will automatically re-install"
+       ewarn "all self installed plugins after Logstash upgrades."
+       elog
+       elog "Installing plugins:"
+       elog "eselect logstash-plugin install logstash-output-gelf"
+       elog
+
+       elog "Reinstalling self installed plugins (installed via eselect module):"
+       eselect logstash-plugin reinstall
+
+       elog
+       elog "Sample configuration:"
+       elog "${EROOT%/}/usr/share/${MY_PN}"
+}