dev-libs/luise-bin: bump to EAPI=7
authorConrad Kostecki <conrad@kostecki.com>
Thu, 10 Oct 2019 17:44:47 +0000 (19:44 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 13 Oct 2019 17:11:25 +0000 (20:11 +0300)
Also taking ownership by myself.
Since links are dead, hosting by myself and adding archive.org.

Closes: https://bugs.gentoo.org/697340
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
Closes: https://github.com/gentoo/gentoo/pull/13252
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-libs/luise-bin/luise-bin-0.1.1-r1.ebuild [new file with mode: 0644]
dev-libs/luise-bin/metadata.xml

diff --git a/dev-libs/luise-bin/luise-bin-0.1.1-r1.ebuild b/dev-libs/luise-bin/luise-bin-0.1.1-r1.ebuild
new file mode 100644 (file)
index 0000000..0b998ae
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="LUIse"
+
+inherit multilib
+
+DESCRIPTION="Programming interface for the Wallbraun LCD-USB-Interface"
+HOMEPAGE="https://web.archive.org/web/20130718114020/http://wallbraun-electronics.de/"
+SRC_URI="https://www.bl4ckb0x.de/files/${MY_PN}_${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="examples"
+
+RDEPEND="virtual/libusb:0"
+
+S="${WORKDIR}/${MY_PN}_${PV}"
+
+QA_PREBUILT="
+       usr/lib/libluise.so.${PV}
+       usr/lib64/libluise.so.${PV}
+"
+
+src_install() {
+       insinto /usr/$(get_libdir)
+       newins $(usex amd64 '64' '32')bit/libluise$(usex amd64 '_64' '').so.${PV} libluise.so.${PV}
+       dosym ../../usr/$(get_libdir)/libluise.so.${PV} /usr/$(get_libdir)/libluise.so.${SLOT}
+       dosym ../../usr/$(get_libdir)/libluise.so.${PV} /usr/$(get_libdir)/libluise.so
+
+       insinto /usr/include
+       doins $(usex amd64 '64' '32')bit/luise.h
+
+       dodoc doc/*
+       use examples && dodoc -r samples/luise-test
+}
index 6f49eba8f49693023f393161560b3a2d9e2717c5..31373f78eb1f2b27b3e5e807b472b4824b7a4749 100644 (file)
@@ -1,5 +1,25 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<!-- maintainer-needed -->
+       <maintainer type="person">
+               <email>ck+gentoo@bl4ckb0x.de</email>
+               <name>Conrad Kostecki</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <longdescription>
+               The libluise.so lib provides a very simple interface for programming
+               the USB LCDs ready. The programmer has three independent screens available,
+               a text screen and two graphic screens. The screens are each 320x240 pixels.
+               By the two separate graphic screens can be very easily superimposed static and
+               represent dynamic data. This is for example when using background images
+               helpful because the environment of the dynamic data / graphics is not constantly recalculated
+               got to. All three screens will appear "on top of each other" on the LCD and will go through
+               previously defined parameters (LUI_LCDmode ()) corresponding to each other bitwise
+               connected. The coordinate origin (x = 0, y = 0) of a screen is always in the
+               left upper corner. In addition, the inversion and the rotation of the screens
+               supports (90 ° steps), while saving the programmer the coordinates conversions stay.
+       </longdescription>
 </pkgmetadata>