Revert "sys-apps/xinetd: drop old"
authorThomas Deutschmann <whissi@gentoo.org>
Mon, 20 Aug 2018 16:45:00 +0000 (18:45 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Mon, 20 Aug 2018 16:55:45 +0000 (18:55 +0200)
This reverts commit 816a4db4f85bdb28d67d0a000c0981288e88c026.

=sys-apps/xinetd-2.3.15-r3 still needed for fbsd.

sys-apps/xinetd/Manifest
sys-apps/xinetd/xinetd-2.3.15-r2.ebuild [new file with mode: 0644]
sys-apps/xinetd/xinetd-2.3.15-r3.ebuild [new file with mode: 0644]

index 1e3b440acf0911e99dc5fc2ce6e0b7ad9491516d..12b8ad8295b994dee2a1766a9f5baaa3bed3cffb 100644 (file)
@@ -1,2 +1,3 @@
 DIST xinetd-2.3.15.3.tar.xz 383204 BLAKE2B dada7e1efb8c70d9b47efbb33de54e643e195fc043a2fe8b1b61a1d9e597a5a10feda8d6692e665af1f1690870e619098a9a2367df3a73f7821a91777532f1fa SHA512 3a744d5ce66da46743eec28d5b95a44709b1828187078984e59d7220ac325abce1198927e9156f343a4e16a9dc63e8846f1dcb0facbf05ea44c73aecbe7e504f
 DIST xinetd-2.3.15.4.tar.xz 384504 BLAKE2B e6981d7143c5e39d45a6274d003467f372b1e97637112c66a3fd3a1cb47fe948228d72c914cca5b2db1d65a626b83ff36f10768d343579aa48353d20e2541f4d SHA512 1d9bbf5f60b299746adf3e57a669bf1a554b50066563b65cdb7584f00dcab2d3d331df705eefb56b51c52a16b5ed6b109cd832c27df87c7f262bb304e17ddc0e
+DIST xinetd-2.3.15.tar.gz 309774 BLAKE2B b5c933a2aa7a2ef4a2d58b53890f04569fe592005c646f39a00d4716325c8ac9b9aa3b8b4b2f2b861430c8415167ab1d394de3d3b4bd761239c5223b1d2b0419 SHA512 9d6fee1fbc90329629d84086ae7de5cd51c25af7b68e52aa704d6f74bee5f0e3d54ca1bcf780f90f74ddc8d336ae0abb5e5e368d43c426a26b8dd2c4676d26aa
diff --git a/sys-apps/xinetd/xinetd-2.3.15-r2.ebuild b/sys-apps/xinetd/xinetd-2.3.15-r2.ebuild
new file mode 100644 (file)
index 0000000..99bf38e
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils flag-o-matic systemd toolchain-funcs
+
+DESCRIPTION="powerful replacement for inetd"
+HOMEPAGE="http://www.xinetd.org/"
+SRC_URI="http://www.xinetd.org/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="perl rpc tcpd"
+
+DEPEND="tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )
+       rpc? ( net-libs/libtirpc:= )"
+RDEPEND="${DEPEND}
+       perl? ( dev-lang/perl )"
+DEPEND="${DEPEND}
+       virtual/pkgconfig"
+
+src_prepare() {
+       epatch "${FILESDIR}"/${PN}-2.3.14-DESTDIR.patch
+       epatch "${FILESDIR}"/${PN}-2.3.14-install-contrib.patch
+       epatch "${FILESDIR}"/${PN}-2.3.14-config.patch
+       epatch "${FILESDIR}"/${PN}-2.3.15-creds.patch #488158
+       find -name Makefile.in -exec sed -i 's:\<ar\>:$(AR):' {} +
+}
+
+src_configure() {
+       if ! use rpc ; then
+               append-cppflags -DNO_RPC
+               export ac_cv_header_{rpc_{rpc,rpcent,pmap_clnt},netdb}_h=no
+       fi
+       tc-export AR PKG_CONFIG
+       LIBS=$(${PKG_CONFIG} --libs libtirpc) \
+       econf \
+               $(use_with tcpd libwrap) \
+               --with-loadavg
+}
+
+src_install() {
+       emake DESTDIR="${ED}" install install-contrib
+       use perl || rm -f "${ED}"/usr/sbin/xconv.pl
+
+       newinitd "${FILESDIR}"/xinetd.rc6 xinetd
+       newconfd "${FILESDIR}"/xinetd.confd xinetd
+       systemd_dounit "${FILESDIR}/${PN}.service"
+
+       newdoc contrib/xinetd.conf xinetd.conf.dist.sample
+       dodoc AUDIT INSTALL README TODO CHANGELOG
+}
diff --git a/sys-apps/xinetd/xinetd-2.3.15-r3.ebuild b/sys-apps/xinetd/xinetd-2.3.15-r3.ebuild
new file mode 100644 (file)
index 0000000..357e0c9
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils flag-o-matic systemd toolchain-funcs
+
+DESCRIPTION="powerful replacement for inetd"
+HOMEPAGE="http://www.xinetd.org/ https://github.com/xinetd-org/xinetd"
+SRC_URI="http://www.xinetd.org/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd"
+IUSE="perl rpc tcpd"
+
+DEPEND="tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )
+       rpc? ( net-libs/libtirpc:= )"
+RDEPEND="${DEPEND}
+       perl? ( dev-lang/perl )"
+DEPEND="${DEPEND}
+       virtual/pkgconfig"
+
+src_prepare() {
+       epatch "${FILESDIR}"/${PN}-2.3.14-DESTDIR.patch
+       epatch "${FILESDIR}"/${PN}-2.3.14-install-contrib.patch
+       epatch "${FILESDIR}"/${PN}-2.3.15-config.patch
+       epatch "${FILESDIR}"/${PN}-2.3.15-creds.patch #488158
+       find -name Makefile.in -exec sed -i 's:\<ar\>:$(AR):' {} +
+}
+
+src_configure() {
+       tc-export AR PKG_CONFIG
+       if use rpc ; then
+               append-cflags $(${PKG_CONFIG} --cflags libtirpc)
+       else
+               append-cppflags -DNO_RPC
+               export ac_cv_header_{rpc_{rpc,rpcent,pmap_clnt},netdb}_h=no
+       fi
+       LIBS=$(${PKG_CONFIG} --libs libtirpc) \
+       econf \
+               $(use_with tcpd libwrap) \
+               --with-loadavg
+}
+
+src_install() {
+       emake DESTDIR="${ED}" install install-contrib
+       use perl || rm -f "${ED}"/usr/sbin/xconv.pl
+
+       newinitd "${FILESDIR}"/xinetd.rc6 xinetd
+       newconfd "${FILESDIR}"/xinetd.confd xinetd
+       systemd_dounit "${FILESDIR}/${PN}.service"
+
+       newdoc contrib/xinetd.conf xinetd.conf.dist.sample
+       dodoc AUDIT INSTALL README TODO CHANGELOG
+}