app-accessibility/caribou: Version bump
authorPacho Ramos <pacho@gentoo.org>
Sat, 20 Feb 2016 11:48:23 +0000 (12:48 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sat, 20 Feb 2016 13:51:43 +0000 (14:51 +0100)
Package-Manager: portage-2.2.27

app-accessibility/caribou/Manifest
app-accessibility/caribou/caribou-0.4.20.ebuild [new file with mode: 0644]

index ca0a7b4d03ae3df6be7b30b2806161ed79d2887a..969fc082b6daea8855ea47ebf1991f582f9ca80a 100644 (file)
@@ -1 +1,2 @@
 DIST caribou-0.4.19.tar.xz 412328 SHA256 2f0bd0c14c5f94cf5ac3a7627018919addf7a054ac84aaa8e62356957c175a44 SHA512 ae8fd278612778eae35810eee199dc9c64b45340de1459cc71eb5806ebc14ddd05e7e0e5464e2976d0160a50c6d76656a7ed0362bfd79eecdc09de1fc78b6de1 WHIRLPOOL db26dbc91e231558712bd33f57f857de660cc17f5c7c6c8c8fd2687807b75d5784df8654e0328c35a4e06902ec5a628609b8c9dd2d568a2afcb59c2f12c081a8
+DIST caribou-0.4.20.tar.xz 415148 SHA256 3a6664d5698c2b62a6c1c115743630d339ac237a7324bb354f2e5d55b4bb50d9 SHA512 e72a18462268278e0c07f178085eeff0e65ece6a9bf2f667c4ca66a66d173b39c68843c537ba6e8bd056c21575be592cece5f4f752f324c7f0db44fe28c45504 WHIRLPOOL e718ab799dcb8474c813e22fae1445d5a299d6c14dfa880cbe3da55793db867a8e5b5ef442a99e184a75a5b6fbf4d5719821a901d75ba69dba74db1d3473c437
diff --git a/app-accessibility/caribou/caribou-0.4.20.ebuild b/app-accessibility/caribou/caribou-0.4.20.ebuild
new file mode 100644 (file)
index 0000000..26c3157
--- /dev/null
@@ -0,0 +1,90 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Input assistive technology intended for switch and pointer users"
+HOMEPAGE="https://wiki.gnome.org/Projects/Caribou"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+       app-accessibility/at-spi2-core
+       >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+       >=x11-libs/gtk+-3:3[introspection]
+       x11-libs/gtk+:2
+       >=dev-libs/gobject-introspection-0.10.7:=
+       dev-libs/libgee:0.8
+       dev-libs/libxml2
+       >=media-libs/clutter-1.5.11:1.0[introspection]
+       x11-libs/libX11
+       x11-libs/libxklavier
+       x11-libs/libXtst
+"
+# gsettings-desktop-schemas is needed for the 'toolkit-accessibility' key
+# pyatspi-2.1.90 needed to run caribou if pygobject:3 is installed
+# librsvg needed to load svg images in css styles
+RDEPEND="${COMMON_DEPEND}
+       dev-libs/glib[dbus]
+       >=dev-python/pyatspi-2.1.90[${PYTHON_USEDEP}]
+       >=gnome-base/gsettings-desktop-schemas-3
+       gnome-base/librsvg:2
+       sys-apps/dbus
+"
+DEPEND="${COMMON_DEPEND}
+       dev-libs/libxslt
+       >=dev-util/intltool-0.35.5
+       virtual/pkgconfig
+"
+
+src_prepare() {
+       # delete custom PYTHONPATH, useless on Gentoo and potential bug source
+       # + caribou is python2 only so fix the shell scripts
+       sed -e '/export PYTHONPATH=.*python/ d' \
+               -e "s:@PYTHON@:${EPREFIX}/usr/bin/python2:" \
+               -i bin/{antler-keyboard,caribou-preferences}.in ||
+               die "sed failed"
+
+       gnome2_src_prepare
+
+       prepare_caribou() {
+               mkdir -p "${BUILD_DIR}" || die
+       }
+       python_foreach_impl prepare_caribou
+}
+
+src_configure() {
+       ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir \
+               gnome2_src_configure \
+                       --disable-docs \
+                       --disable-static \
+                       --enable-gtk3-module \
+                       --enable-gtk2-module \
+                       VALAC=$(type -P true)
+       # vala is not needed for tarball builds, but configure checks for it...
+}
+
+src_compile() {
+       python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_test() {
+       python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+       python_foreach_impl run_in_build_dir gnome2_src_install
+       dodoc AUTHORS NEWS README # ChangeLog simply points to git log
+}