sci-libs/scipy: disable parallel build completely.
authorBenda Xu <heroxbd@gentoo.org>
Mon, 27 Jan 2020 04:54:55 +0000 (12:54 +0800)
committerBenda Xu <heroxbd@gentoo.org>
Mon, 27 Jan 2020 04:59:38 +0000 (12:59 +0800)
  After 4 years discussion and debugging, we conclude that Python 3 is
  deeply broken in parallel builds for anything involving compiling of
  C/C++/fortran code.  The problem is universal, regardless how
  dev-python/numpy is built.

  Numpy and scipy upstream cannot do anything about this.  We bite the
  bullet and disable parallel build of scipy completely.

  Thanks to all who have contributed to this heroic marathon
  debugging.  We regret that only a workaround can be provided at this
  moment.

Credit: Andrés Becerra Sandoval, Hendrik v. Raven, younky.yang@yahoo.com
Credit: matoro, Denis Descheneaux, Mathy Vanvoorden, email200202@yahoo.com
Credit: jon R-B, Anton Kochkov, Jonas Stein, edes, David Duchesne
Credit: thulle, Mathy Vanvoorden, Sasha Medvedev, rtgiskard@gmail.com
Credit: Lukasz Ligowski, Zentoo, Jouni Kosonen, Neil, Harris Landgarten
Credit: Markus Oehme, Andreas Proteus
Suggested-By: François Bissey, Arfrever Frehtes Taifersar Arahesis
Reference: https://github.com/numpy/numpy/issues/13080
Reference: https://github.com/scipy/scipy/issues/7112
Closes: https://bugs.gentoo.org/614464
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Benda Xu <heroxbd@gentoo.org>
sci-libs/scipy/scipy-1.4.1.ebuild

index a9e7e584875f848023f92d3e8c831352256dfe8f..b176683c887066e325614337c284df91a2ecf89b 100644 (file)
@@ -108,6 +108,8 @@ python_prepare_all() {
 
 python_compile() {
        # FIXME: parallel python building fails, bug #614464
+       export MAKEOPTS=-j1
+
        ${EPYTHON} tools/cythonize.py || die
        distutils-r1_python_compile \
                ${SCIPY_FCONFIG}