old
authorMike Frysinger <vapier@gentoo.org>
Sat, 9 Dec 2006 08:12:04 +0000 (08:12 +0000)
committerMike Frysinger <vapier@gentoo.org>
Sat, 9 Dec 2006 08:12:04 +0000 (08:12 +0000)
sys-apps/sysvinit/files/digest-sysvinit-2.86-r3 [deleted file]
sys-apps/sysvinit/files/digest-sysvinit-2.86-r4 [deleted file]
sys-apps/sysvinit/sysvinit-2.86-r3.ebuild [deleted file]
sys-apps/sysvinit/sysvinit-2.86-r4.ebuild [deleted file]

diff --git a/sys-apps/sysvinit/files/digest-sysvinit-2.86-r3 b/sys-apps/sysvinit/files/digest-sysvinit-2.86-r3
deleted file mode 100644 (file)
index 7fc9a56..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 650af823f937d386e81520b1741d4d45 sysvinit-2.86-kexec.patch 4139
-RMD160 5f8e9ccd3a39701cf47a1a541c78a4be971d46fc sysvinit-2.86-kexec.patch 4139
-SHA256 936245ef3060939bec3099efc006009336b3672422c1de41983b277ab5ddac47 sysvinit-2.86-kexec.patch 4139
-MD5 7d5d61c026122ab791ac04c8a84db967 sysvinit-2.86.tar.gz 99009
-RMD160 46587ab51390b5c8cd3179a3690f86efdbe9b4b9 sysvinit-2.86.tar.gz 99009
-SHA256 035f98fae17d9cff002993c564ccc83dc4ed136127172caeff872b6abdb679d8 sysvinit-2.86.tar.gz 99009
diff --git a/sys-apps/sysvinit/files/digest-sysvinit-2.86-r4 b/sys-apps/sysvinit/files/digest-sysvinit-2.86-r4
deleted file mode 100644 (file)
index 7fc9a56..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 650af823f937d386e81520b1741d4d45 sysvinit-2.86-kexec.patch 4139
-RMD160 5f8e9ccd3a39701cf47a1a541c78a4be971d46fc sysvinit-2.86-kexec.patch 4139
-SHA256 936245ef3060939bec3099efc006009336b3672422c1de41983b277ab5ddac47 sysvinit-2.86-kexec.patch 4139
-MD5 7d5d61c026122ab791ac04c8a84db967 sysvinit-2.86.tar.gz 99009
-RMD160 46587ab51390b5c8cd3179a3690f86efdbe9b4b9 sysvinit-2.86.tar.gz 99009
-SHA256 035f98fae17d9cff002993c564ccc83dc4ed136127172caeff872b6abdb679d8 sysvinit-2.86.tar.gz 99009
diff --git a/sys-apps/sysvinit/sysvinit-2.86-r3.ebuild b/sys-apps/sysvinit/sysvinit-2.86-r3.ebuild
deleted file mode 100644 (file)
index e036c57..0000000
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/sysvinit-2.86-r3.ebuild,v 1.4 2006/01/17 02:15:50 vapier Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="/sbin/init - parent of all processes"
-HOMEPAGE="http://freshmeat.net/projects/sysvinit/"
-SRC_URI="ftp://ftp.cistron.nl/pub/people/miquels/software/${P}.tar.gz
-       ftp://sunsite.unc.edu/pub/Linux/system/daemons/init/${P}.tar.gz
-       http://www.gc-linux.org/down/isobel/kexec/sysvinit/sysvinit-2.86-kexec.patch"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE="selinux bootstrap build ibm static"
-
-RDEPEND="selinux? ( >=sys-libs/libselinux-1.18 sys-libs/libsepol )"
-DEPEND="${RDEPEND}
-       virtual/os-headers"
-
-src_unpack() {
-       unpack ${P}.tar.gz
-       cd "${S}"
-       epatch "${FILESDIR}"/${P}-docs.patch
-       epatch "${FILESDIR}"/${P}-shutdown-usage.patch
-       epatch "${FILESDIR}"/sysvinit-2.86-off-by-one.patch
-       epatch "${DISTDIR}"/sysvinit-2.86-kexec.patch
-       epatch "${FILESDIR}"/sysvinit-2.86-POSIX-1003.1e.patch #5818
-       epatch "${FILESDIR}"/sysvinit-2.86-execl.patch
-       epatch "${FILESDIR}"/sysvinit-2.86-utmp-64bit.patch
-       cd src
-       epatch "${FILESDIR}"/${PV}-gentoo.patch
-       use selinux && epatch "${FILESDIR}"/${PV}-selinux.patch
-
-       # Mung inittab for specific architectures
-       cd "${WORKDIR}"
-       cp "${FILESDIR}"/inittab . || die "cp inittab"
-       local insert=""
-       if use ibm ; then
-               insert="#hvc0:2345:respawn:/sbin/agetty -L 9600 hvc0"$'\n'
-               insert="${insert}#hvsi:2345:respawn:/sbin/agetty -L 19200 hvsi0"
-       fi
-       use arm && insert='#f0:12345:respawn:/sbin/agetty 9600 ttyFB0 vt100'
-       use hppa && insert='b0:12345:respawn:/sbin/agetty 9600 ttyB0 vt100'
-       (use arm || use mips || use sh || use sparc) && sed -i '/ttyS0/s:#::' inittab
-       [[ -n ${insert} ]] && echo "# Architecture specific features"$'\n'"${insert}" >> inittab
-}
-
-src_compile() {
-       use static && append-ldflags -static
-
-       # Note: The LCRYPT define below overrides the test in
-       # sysvinit's Makefile.  This is because sulogin must be linked
-       # to libcrypt in any case, but when building stage2 in
-       # catalyst, /usr/lib/libcrypt.a isn't available.  In truth
-       # this doesn't change how sulogin is built since ld would use
-       # the shared obj by default anyway!  The other option is to
-       # refrain from building sulogin, but that isn't a good option.
-       # (09 Jul 2004 agriffis)
-       emake -C src \
-               CC="$(tc-getCC)" \
-               DISTRO="Gentoo" \
-               LCRYPT="-lcrypt" \
-               || die
-}
-
-src_install() {
-       dodoc README doc/*
-
-       cd src
-       make install DISTRO="Gentoo" ROOT="${D}" || die "make install"
-
-       insinto /etc
-       doins "${WORKDIR}"/inittab || die "inittab"
-}
-
-pkg_postinst() {
-       # Reload init to fix unmounting problems of / on next reboot.
-       # This is really needed, as without the new version of init cause init
-       # not to quit properly on reboot, and causes a fsck of / on next reboot.
-       if [[ ${ROOT} == / ]] && ! use build && ! use bootstrap; then
-               # Do not return an error if this fails
-               /sbin/telinit U &>/dev/null
-       fi
-}
diff --git a/sys-apps/sysvinit/sysvinit-2.86-r4.ebuild b/sys-apps/sysvinit/sysvinit-2.86-r4.ebuild
deleted file mode 100644 (file)
index 693c9fc..0000000
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sysvinit/sysvinit-2.86-r4.ebuild,v 1.1 2006/02/07 01:22:59 pebenito Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="/sbin/init - parent of all processes"
-HOMEPAGE="http://freshmeat.net/projects/sysvinit/"
-SRC_URI="ftp://ftp.cistron.nl/pub/people/miquels/software/${P}.tar.gz
-       ftp://sunsite.unc.edu/pub/Linux/system/daemons/init/${P}.tar.gz
-       http://www.gc-linux.org/down/isobel/kexec/sysvinit/sysvinit-2.86-kexec.patch"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="selinux bootstrap build ibm static"
-
-RDEPEND="selinux? ( >=sys-libs/libselinux-1.28 )"
-DEPEND="${RDEPEND}
-       virtual/os-headers"
-
-src_unpack() {
-       unpack ${P}.tar.gz
-       cd "${S}"
-       epatch "${FILESDIR}"/${P}-docs.patch
-       epatch "${FILESDIR}"/${P}-shutdown-usage.patch
-       epatch "${FILESDIR}"/sysvinit-2.86-off-by-one.patch
-       epatch "${DISTDIR}"/sysvinit-2.86-kexec.patch
-       epatch "${FILESDIR}"/sysvinit-2.86-POSIX-1003.1e.patch #5818
-       epatch "${FILESDIR}"/sysvinit-2.86-execl.patch
-       epatch "${FILESDIR}"/sysvinit-2.86-utmp-64bit.patch
-       cd src
-       epatch "${FILESDIR}"/${PV}-gentoo.patch
-       use selinux && epatch "${FILESDIR}"/${PV}-selinux-1.patch
-
-       # Mung inittab for specific architectures
-       cd "${WORKDIR}"
-       cp "${FILESDIR}"/inittab . || die "cp inittab"
-       local insert=""
-       if use ibm ; then
-               insert="#hvc0:2345:respawn:/sbin/agetty -L 9600 hvc0"$'\n'
-               insert="${insert}#hvsi:2345:respawn:/sbin/agetty -L 19200 hvsi0"
-       fi
-       use arm && insert='#f0:12345:respawn:/sbin/agetty 9600 ttyFB0 vt100'
-       use hppa && insert='b0:12345:respawn:/sbin/agetty 9600 ttyB0 vt100'
-       (use arm || use mips || use sh || use sparc) && sed -i '/ttyS0/s:#::' inittab
-       [[ -n ${insert} ]] && echo "# Architecture specific features"$'\n'"${insert}" >> inittab
-}
-
-src_compile() {
-       use static && append-ldflags -static
-
-       # Note: The LCRYPT define below overrides the test in
-       # sysvinit's Makefile.  This is because sulogin must be linked
-       # to libcrypt in any case, but when building stage2 in
-       # catalyst, /usr/lib/libcrypt.a isn't available.  In truth
-       # this doesn't change how sulogin is built since ld would use
-       # the shared obj by default anyway!  The other option is to
-       # refrain from building sulogin, but that isn't a good option.
-       # (09 Jul 2004 agriffis)
-       emake -C src \
-               CC="$(tc-getCC)" \
-               DISTRO="Gentoo" \
-               LCRYPT="-lcrypt" \
-               || die
-}
-
-src_install() {
-       dodoc README doc/*
-
-       cd src
-       make install DISTRO="Gentoo" ROOT="${D}" || die "make install"
-
-       insinto /etc
-       doins "${WORKDIR}"/inittab || die "inittab"
-}
-
-pkg_postinst() {
-       # Reload init to fix unmounting problems of / on next reboot.
-       # This is really needed, as without the new version of init cause init
-       # not to quit properly on reboot, and causes a fsck of / on next reboot.
-       if [[ ${ROOT} == / ]] && ! use build && ! use bootstrap; then
-               # Do not return an error if this fails
-               /sbin/telinit U &>/dev/null
-       fi
-}