dev-python/fabric: RESTRICT test
authorVirgil Dupras <vdupras@gentoo.org>
Fri, 10 May 2019 18:01:05 +0000 (14:01 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Fri, 10 May 2019 18:05:59 +0000 (14:05 -0400)
Depend on pytest-relaxed which is broken.

Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-python/fabric/fabric-2.3.1.ebuild

index c6273f4e440a9287f08c6f323338c6711f31753f..8265a2381332df360b8489832ad65cd1d875cf0a 100644 (file)
@@ -14,7 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="2"
 KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc fab2 test"
+IUSE="doc fab2"
 
 RDEPEND="
        !fab2? ( !dev-python/fabric:0 )
@@ -28,13 +28,11 @@ BDEPEND="
                dev-python/alabaster[${PYTHON_USEDEP}]
                >=dev-python/sphinx-1.4[${PYTHON_USEDEP}]
                <dev-python/sphinx-1.7[${PYTHON_USEDEP}]
-       )
-       test? (
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               >=dev-python/pytest-relaxed-1.1.4[${PYTHON_USEDEP}]
        )"
 
+# Depends on pytest-relaxed which is broken
+RESTRICT="test"
+
 python_compile() {
        if use fab2; then
                export PACKAGE_AS_FABRIC2=1
@@ -49,11 +47,6 @@ python_compile_all() {
        fi
 }
 
-python_test() {
-       # -p pytest_relaxed: this plugin has to be loaded explicitly
-       pytest -s -v -p pytest_relaxed.plugin || die "Tests failed"
-}
-
 python_install_all() {
        use doc && local HTML_DOCS=( sites/docs/html/. )
        distutils-r1_python_install_all