dev-python/fasteners: fix MissingTestRestrict
authorWim Muskee <wimmuskee@gmail.com>
Sun, 8 Dec 2019 07:41:37 +0000 (08:41 +0100)
committerMatthew Thode <prometheanfire@gentoo.org>
Sun, 8 Dec 2019 08:31:46 +0000 (02:31 -0600)
Signed-off-by: Wim Muskee <wimmuskee@gmail.com>
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/fasteners/fasteners-0.14.1-r1.ebuild
dev-python/fasteners/fasteners-0.14.1.ebuild

index 3f62ea4e6d5e517ab71b04f0e2cd3699e04c4db0..156cb0c1936158ed5dc694edf1215031c6a90d60 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7,7} pypy )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
 
 inherit distutils-r1
 
@@ -14,6 +14,7 @@ LICENSE="Apache-2.0"
 SLOT="0"
 KEYWORDS="amd64 ~arm arm64 ~x86 ~amd64-linux ~x86-linux"
 IUSE="test"
+RESTRICT="!test? ( test )"
 
 RDEPEND="
        >=dev-python/monotonic-0.1[${PYTHON_USEDEP}]
index c722a8f6fbf99457c64f4915eda45d9527b7078f..ef49731e5f0bd872ce46b4476dd88cbaa2ad1352 100644 (file)
@@ -15,6 +15,7 @@ LICENSE="Apache-2.0"
 SLOT="0"
 KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
 IUSE="test"
+RESTRICT="!test? ( test )"
 
 RDEPEND="
        >=dev-python/monotonic-0.1[${PYTHON_USEDEP}]