Fix autotools rebuilding, thanks to Patrick Lauer in bug #153362.
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Sun, 29 Oct 2006 22:40:11 +0000 (22:40 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Sun, 29 Oct 2006 22:40:11 +0000 (22:40 +0000)
Package-Manager: portage-2.1.2_rc1-r1

media-sound/takcd/ChangeLog
media-sound/takcd/files/digest-takcd-0.10
media-sound/takcd/takcd-0.10.ebuild

index 5bf7a71dc0c582490ff7f39ec05219fb524ecf31..47ae54d851486b17bcbe676ede11c90b38049ba2 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for media-sound/takcd
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/takcd/ChangeLog,v 1.10 2005/09/15 19:59:03 agriffis Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/takcd/ChangeLog,v 1.11 2006/10/29 22:40:11 flameeyes Exp $
+
+  29 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> takcd-0.10.ebuild:
+  Fix autotools rebuilding, thanks to Patrick Lauer in bug #153362.
 
   15 Sep 2005; Aron Griffis <agriffis@gentoo.org> takcd-0.10.ebuild:
   Mark 0.10 stable on alpha
index 5c76dd69c0e8430b99ba6a2d91e84152b56ecb55..d282bdf70317cf5eadf49800ce5139996f1780e7 100644 (file)
@@ -1 +1,3 @@
 MD5 2cd3da060ea1d20d46aa5065031147a1 takcd-0.10.tar.gz 95457
+RMD160 2784989499ba9e999b1b59c8749d702de1ba446e takcd-0.10.tar.gz 95457
+SHA256 2871ace2ec79b09ea8eff80a2074105fdde33d3fb0a0572dc8e2dd931c8d4802 takcd-0.10.tar.gz 95457
index 8edcd6e58735322d6c265bb1172d9b977e801f1e..823b4a538d1b9c06c8476b7abfe3115533f9e027 100644 (file)
@@ -1,6 +1,11 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/takcd/takcd-0.10.ebuild,v 1.10 2005/09/15 19:59:03 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/takcd/takcd-0.10.ebuild,v 1.11 2006/10/29 22:40:11 flameeyes Exp $
+
+WANT_AUTOMAKE="1.4"
+WANT_AUTOCONF="2.5"
+
+inherit autotools
 
 IUSE=""
 
@@ -12,15 +17,14 @@ SLOT="0"
 LICENSE="GPL-2"
 KEYWORDS="alpha amd64 ~hppa ia64 ~mips ~ppc sparc x86"
 
-RDEPEND="virtual/libc"
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
 
-DEPEND="sys-devel/autoconf
-       sys-devel/automake"
+       eautoreconf
+}
 
 src_compile() {
-       export WANT_AUTOMAKE=1.4
-       export WANT_AUTOCONF=2.5
-       ./autogen.sh
        emake || die
 }