dev-python/snakeoil: version bump
authorTim Harder <radhermit@gentoo.org>
Mon, 24 Aug 2015 00:11:05 +0000 (20:11 -0400)
committerTim Harder <radhermit@gentoo.org>
Mon, 24 Aug 2015 00:11:05 +0000 (20:11 -0400)
dev-python/snakeoil/Manifest
dev-python/snakeoil/snakeoil-0.6.5.ebuild [new file with mode: 0644]

index cfb1dccb0039d96b875ac8627c9717308a43ab5f..986b5241d5632a3aa8c3d0798bf7cb3b28ccae05 100644 (file)
@@ -1 +1,2 @@
 DIST snakeoil-0.6.4.tar.gz 192291 SHA256 8636918381db16bf910afcb30a5e8722038afda32fbf41a977fabea75775131e SHA512 c2290801426de1fd6fe3e668edfc36e05cf50a6990f336eb604eece27f56716b5cff672ca7642906636fa1a8afa82f37867e898680f54b154c37cf51ef72eb9e WHIRLPOOL 08c778296f0881c1884eb0c23fc2e4e81b28f406971d84d71641ac4b4b864e8f472c06fad2937d279565b627ef983f89dbe6e6e1a5dbe7b4263ac00b5d76aea5
+DIST snakeoil-0.6.5.tar.gz 195182 SHA256 af02d9e28097083683d29267ed8b1a748d9a5f4a822fe733176b92fc8793cb33 SHA512 44895dd4ea72d1d43afddb7b1b13009c21b1c26fab30d7b2fa29115ca62202b3a1a311f22f9d925a78650d1c1012313e98783ebc5c0cb37b0e70aae0f1e14371 WHIRLPOOL 8886591e7e87de91f413cdab384c938d2a1ebbb0569601559fb2fd62329eb19936743211cbc0988af781f95e5c40dea2ac4b141f194fe72e74d89fe43d83cf59
diff --git a/dev-python/snakeoil/snakeoil-0.6.5.ebuild b/dev-python/snakeoil/snakeoil-0.6.5.ebuild
new file mode 100644 (file)
index 0000000..218588c
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
+       inherit git-r3
+else
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="Miscellaneous python utility code"
+HOMEPAGE="http://github.com/pkgcore/snakeoil"
+
+LICENSE="BSD"
+SLOT="0"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_configure_all() {
+       # disable snakeoil 2to3 caching
+       unset PY2TO3_CACHEDIR
+}
+
+python_test() {
+       esetup.py test
+}