dev-python/hypothesis: Bump to 4.55.2
authorMichał Górny <mgorny@gentoo.org>
Tue, 17 Dec 2019 12:20:17 +0000 (13:20 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 17 Dec 2019 13:16:48 +0000 (14:16 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/hypothesis/Manifest
dev-python/hypothesis/hypothesis-4.55.2.ebuild [new file with mode: 0644]

index 95dae88740ad10c1f8aa7314ed32c377c7f3d75f..dc76e15500a61cb5c71f73bceb7c4f06b312f6af 100644 (file)
@@ -2,3 +2,4 @@ DIST hypothesis-python-4.15.0.tar.gz 1175925 BLAKE2B f3e3888b3f4e542d567bdaad258
 DIST hypothesis-python-4.47.5.tar.gz 6805022 BLAKE2B 737a558c794f3ac428bef4b38858d47fddba613ce37eb9a9554afa3c189776e9172965dd31f8497747ac13b2ab1d34ee6de8671646972e71b82c5260db489b9a SHA512 9b6920181dca75b9e551ae5e598101f35cfc26e9e3a1b20cab652c151bc6355413d0c9602d3242fb23f808ab00335793009df938d55ee19a6af1ce2a8b085e3c
 DIST hypothesis-python-4.50.8.tar.gz 6814518 BLAKE2B f2c39cae3708fe88d1854cda97633ba420c32fda38093bb852ef45929762cade0f7f0d1ef696ff96f7ebe7460e8bf53f63de9c959bbbd9e8ec162196d307aac0 SHA512 8c77439fd029e2380afbc059d2edf977414997ba81ecdfde14dfe9dbe9515a92e701751d13879c6b879271f817e01926c2dc66945ae76eb141818da1775bc545
 DIST hypothesis-python-4.55.1.tar.gz 9002112 BLAKE2B 16c0c0def078abf2847ce55617c1bfdc93dc085128764fff09724df148b41fd4669ddbee7d9c34f47249283e37b32585fc758e3c6d4cb2035049c3dbf382e568 SHA512 d079bcfce6a37ebf245288d9c615fd0328daa90d81d3dd51a38d351fef4a9da5a79c6abcb63a4f39a71240ae82c5af122f6b01c482225e81889e8474068d6c1a
+DIST hypothesis-python-4.55.2.tar.gz 9002965 BLAKE2B 16d46687e787673f1b033037064cbc47edfe517ae6464f8ab5924336240ab87ab24d27b547f41c3888e4609ff4100347485dcc3ba414dc37dad6b170deae0ae4 SHA512 056821a6f03cd564cfe87a0190fb4a4e1b08068e8f5637241859023b44a7600c9ca8508aa9e38464b880c2018753e5010ec9f047959603885175e3c308c3c2bb
diff --git a/dev-python/hypothesis/hypothesis-4.55.2.ebuild b/dev-python/hypothesis/hypothesis-4.55.2.ebuild
new file mode 100644 (file)
index 0000000..145b07e
--- /dev/null
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' pypy)
+       >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               ${RDEPEND}
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/pexpect[${PYTHON_USEDEP}]
+               >=dev-python/pytest-4.3[${PYTHON_USEDEP}]
+               !!<dev-python/typing-3.7.4.1
+       )
+"
+
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+src_prepare() {
+       # avoid pytest-xdist dep for one test
+       sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+               tests/pytest/test_statistics.py || die
+       distutils-r1_src_prepare
+}
+
+python_test() {
+       local pyver=$(python_is_python3 && echo 3 || echo 2)
+       pytest -vv tests/cover tests/pytest tests/py${pyver} ||
+               die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+       optfeature "datetime support" dev-python/pytz
+       optfeature "dateutil support" dev-python/python-dateutil
+       optfeature "numpy support" dev-python/numpy
+       optfeature "django support" dev-python/django dev-python/pytz
+       optfeature "pandas support" dev-python/pandas
+       optfeature "pytest support" dev-python/pytest
+}