net-libs/libpsl: python3_8 support
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 17 Apr 2020 16:04:27 +0000 (18:04 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 17 Apr 2020 18:54:55 +0000 (20:54 +0200)
Tests passed.

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
net-libs/libpsl/libpsl-0.21.0.ebuild

index 973bf4d107b23d10ce8b8ed8886603651eca2fd6..2db775b91e56e702cc2ddc90b56da3b23495b16b 100644 (file)
@@ -2,16 +2,16 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=(python3_{6,7})
 
+PYTHON_COMPAT=(python3_{6,7,8})
 inherit multilib-minimal python-any-r1
 
 DESCRIPTION="C library for the Public Suffix List"
 HOMEPAGE="https://github.com/rockdaboot/libpsl"
 SRC_URI="https://github.com/rockdaboot/${PN}/releases/download/${P}/${P}.tar.gz"
+
 LICENSE="MIT"
 SLOT="0"
-
 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv s390 sparc x86"
 IUSE="icu +idn +man"
 
@@ -22,12 +22,8 @@ RDEPEND="
                net-dns/libidn2:=[${MULTILIB_USEDEP}]
        )
 "
-
-DEPEND="
-       ${RDEPEND}
-"
-BDEPEND="
-       ${PYTHON_DEPS}
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
        dev-util/gtk-doc-am
        sys-devel/gettext
        virtual/pkgconfig