dev-python/pytest-subtesthack: Enable py3.{7,8}, modernize
authorMichał Górny <mgorny@gentoo.org>
Sat, 25 Apr 2020 18:19:48 +0000 (20:19 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 25 Apr 2020 18:44:59 +0000 (20:44 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild

index 8de886930db23e59536a82647097e96c153014cd..87ae193d0678a5674e26d0cea56b06bbe4fc744c 100644 (file)
@@ -1,9 +1,11 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
 
-PYTHON_COMPAT=( python3_6 )
 inherit distutils-r1
 
 DESCRIPTION="A hack for test fixtures, needed for hypothesis inside py.test"
@@ -27,5 +29,5 @@ DEPEND="${RDEPEND}
 
 python_test() {
        distutils_install_for_testing
-       py.test -v || die "Tests fail with ${EPYTHON}"
+       pytest -vv || die "Tests fail with ${EPYTHON}"
 }