dev-ros/urg_node: bump to 0.1.13
authorAlexis Ballier <aballier@gentoo.org>
Mon, 18 May 2020 16:52:45 +0000 (18:52 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 18 May 2020 16:54:37 +0000 (18:54 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/urg_node/Manifest
dev-ros/urg_node/urg_node-0.1.13.ebuild [new file with mode: 0644]
dev-ros/urg_node/urg_node-9999.ebuild

index 78c2c6f27abd36dbf7d16622a517d94dc1ea9998..e9aed7cd380c19ee70691051a830c987945316f8 100644 (file)
@@ -1,2 +1,3 @@
 DIST urg_node-0.1.10.tar.gz 13661 BLAKE2B 1c721427b42e62c104c1f0667586ffd810ed9573f0fc8522bf816aa79233d0b212d253a4360f660437ae7d5418864caaaa9a83ea3d960050567273bc7810dbe8 SHA512 578e7ae98de82b1563806319c0b47a22a878470479434a9c205f3bf3f087dc9108619f17aa86e591a9fb5b88029b6de8711d8388bcaf259601cf88bef5c1f889
 DIST urg_node-0.1.11.tar.gz 19367 BLAKE2B 053b7f6ddbf6b993b37643bcb27c7babae71fd2c0c6e4800be568890331b16f4ec343afe3d2caf1387a2656e73b6cf31055994966489bbaab5651e371dc15bc2 SHA512 41981323ea08e81abca70375793153bdcb52eb54df388978a2e54bdb798c89be3fd4b80c5bf7c28cce62ec3b937f950738bdf4d1e24c9b37e72ee2ca048c542d
+DIST urg_node-0.1.13.tar.gz 20949 BLAKE2B e85653ec46dd85aa62e4e5f06c4d4c775a2d616f0b4daa80584bf81010ad06acbec7f73e0b4a238618c36ec83d07e4dd513fafa9b29e197ad21b56ec02fe4452 SHA512 be503538a293fa0cdf6e7902c0faa5c866a2298193f4ad6cce705dab90220955d4cb21087d84d10ff7d2daf29f362391f17a038496f3036934c57e12f3270a30
diff --git a/dev-ros/urg_node/urg_node-0.1.13.ebuild b/dev-ros/urg_node/urg_node-0.1.13.ebuild
new file mode 100644 (file)
index 0000000..b1e6973
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-drivers/urg_node"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+
+inherit ros-catkin
+
+DESCRIPTION="ROS wrapper for the Hokuyo urg_c library"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/urg_c
+       dev-ros/tf
+       dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+       dev-ros/nodelet
+       dev-ros/rosconsole
+       dev-ros/roscpp
+       dev-ros/diagnostic_updater
+       dev-ros/laser_proc
+       dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
index c475a8ab1d4471b7204832ff3db88165086abf1c..b1e6973afc9f7d32efb84049850a4f5be64e528d 100644 (file)
@@ -1,10 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 ROS_REPO_URI="https://github.com/ros-drivers/urg_node"
 KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
 CATKIN_HAS_MESSAGES=yes
 
 inherit ros-catkin
@@ -23,8 +22,9 @@ RDEPEND="
        dev-ros/roscpp
        dev-ros/diagnostic_updater
        dev-ros/laser_proc
+       dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
        dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
        dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
-       dev-libs/boost:=
 "
-DEPEND="${RDEPEND}"