dev-util/jarwizard: Bump to EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Sat, 9 Nov 2019 21:36:56 +0000 (22:36 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 9 Nov 2019 21:36:56 +0000 (22:36 +0100)
Closes: https://bugs.gentoo.org/697322
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-util/jarwizard/jarwizard-2.50.ebuild

index 2539b1a4610254e375364c8ef2773f47c900b87e..d10d098ad575e7c86ce2cdb009d71e9129c92ddd 100644 (file)
@@ -1,27 +1,28 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 inherit java-pkg-2 java-ant-2
 
 DESCRIPTION="Takes the hassle out of creating executable JAR files for your Java programs"
 SRC_URI="mirror://sourceforge/jarwizard/${PN}_${PV/./}_src.zip"
 HOMEPAGE="https://sourceforge.net/projects/jarwizard/"
+
 SLOT="0"
 LICENSE="GPL-2"
 KEYWORDS="~amd64 x86"
+IUSE=""
+
 DEPEND=">=virtual/jdk-1.5
-               app-arch/unzip"
+       app-arch/unzip"
 RDEPEND=">=virtual/jre-1.5"
 
-IUSE=""
-
 S="${WORKDIR}/${PN}"
 
-src_unpack() {
-       unpack ${A}
-       java-ant_bsfix_one "${S}/nbproject/build-impl.xml"
+src_prepare() {
+       java-pkg-2_src_prepare
+       java-ant_bsfix_one nbproject/build-impl.xml
 }
 
 src_install() {