app-crypt/gpa: version bump
authorAlon Bar-Lev <alonbl@gentoo.org>
Wed, 17 Oct 2018 06:38:22 +0000 (09:38 +0300)
committerAlon Bar-Lev <alonbl@gentoo.org>
Wed, 17 Oct 2018 06:38:22 +0000 (09:38 +0300)
Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org>
Package-Manager: Portage-2.3.49, Repoman-2.3.11

app-crypt/gpa/Manifest
app-crypt/gpa/gpa-0.10.0.ebuild [new file with mode: 0644]

index fefac30f5ef2152cec5b2c12f281bf55b9134016..5048b5206d9234c5469d5cd5dcb8aa4abcd1d377 100644 (file)
@@ -1 +1,2 @@
+DIST gpa-0.10.0.tar.bz2 782455 BLAKE2B ef663432cbe20fb5c543696627f448b3970099b6a0f8f68b57e3d87af03550597adcfe4c27c2774d1f278cfc9d07a089652f42ef4f8c3cbc0192b645c465ac0e SHA512 87004fb0806e76012bc194f95afe9ef6044aec890b26e845f45c314e1bd8864f056ba5e32f9ef2e15b24b50840235e6e548a5e3006b255b4f1c20e0fd7710a3b
 DIST gpa-0.9.10.tar.bz2 763239 BLAKE2B 60763d63c39ca73c5f36d569e27388650060989386df10a867b0235d1b37ce3a46f1526668a1975b9e8c9ebd1c98ffaedab0fe92e55c80787a24dd412939e6a4 SHA512 ff81a78e6b7c46307af6648a2e691a5e8185db229ccc5e259f2c3c05a3c86b337dde492069e7e9510c155fbc64d71cc4e2f109a00400bfb7560c558b753c42a9
diff --git a/app-crypt/gpa/gpa-0.10.0.ebuild b/app-crypt/gpa/gpa-0.10.0.ebuild
new file mode 100644 (file)
index 0000000..3c2d680
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="The GNU Privacy Assistant (GPA) is a graphical user interface for GnuPG"
+HOMEPAGE="http://gpa.wald.intevation.org"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="
+       >=app-crypt/gnupg-2:=
+       >=app-crypt/gpgme-1.5.0:=
+       >=dev-libs/libassuan-1.1.0
+       >=dev-libs/libgpg-error-1.4
+       >=x11-libs/gtk+-2.10.0:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+       nls? ( sys-devel/gettext )"
+
+src_prepare() {
+       default
+       sed -i 's/Application;//' gpa.desktop
+}
+
+src_configure() {
+       econf \
+               --with-gpgme-prefix=/usr \
+               --with-libassuan-prefix=/usr \
+               $(use_enable nls) \
+               GPGKEYS_LDAP="/usr/libexec/gpgkeys_ldap"
+}