dev-util/squashdelta: Bump to EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Sun, 5 Jan 2020 14:46:48 +0000 (15:46 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 5 Jan 2020 15:17:54 +0000 (16:17 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-util/squashdelta/squashdelta-0.1.1.ebuild
dev-util/squashdelta/squashdelta-9999.ebuild

index 9f6ebdce8b9d6a578f9440326bbdb1b0089ea0e2..ea0756376a3dbf652644c8e8dd9ff39f5a259ca6 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 DESCRIPTION="Efficient (partially uncompressed) SquashFS binary delta tool"
 HOMEPAGE="https://github.com/mgorny/squashdelta/"
@@ -12,6 +12,8 @@ LICENSE="BSD public-domain"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="lz4 +lzo"
+# SquashDelta does not make much sense without a compression algo.
+REQUIRED_USE="|| ( lz4 lzo )"
 
 COMMON_DEPEND="
        lz4? ( app-arch/lz4:0= )
@@ -20,9 +22,6 @@ RDEPEND="${COMMON_DEPEND}
        dev-util/xdelta:3"
 DEPEND=${COMMON_DEPEND}
 
-# SquashDelta does not make much sense without a compression algo.
-REQUIRED_USE="|| ( lz4 lzo )"
-
 src_configure() {
        local myconf=(
                $(use_enable lz4)
index fd19fe30514128e42af2f81faf8e314e39abb14d..af4bc7cf66baad191105153b68553e0d11386ada 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 EGIT_REPO_URI="https://github.com/mgorny/${PN}.git"
 inherit autotools git-r3
@@ -15,6 +15,8 @@ LICENSE="BSD public-domain"
 SLOT="0"
 KEYWORDS=""
 IUSE="lz4 +lzo"
+# SquashDelta does not make much sense without a compression algo.
+REQUIRED_USE="|| ( lz4 lzo )"
 
 COMMON_DEPEND="
        lz4? ( app-arch/lz4:0= )
@@ -23,9 +25,6 @@ RDEPEND="${COMMON_DEPEND}
        dev-util/xdelta:3"
 DEPEND=${COMMON_DEPEND}
 
-# SquashDelta does not make much sense without a compression algo.
-REQUIRED_USE="|| ( lz4 lzo )"
-
 src_prepare() {
        default
        eautoreconf