app-forensics/openscap: bump to 1.2.13
authorMarek Szuba <marecki@gentoo.org>
Fri, 17 Mar 2017 12:12:49 +0000 (13:12 +0100)
committerMarek Szuba <marecki@gentoo.org>
Fri, 17 Mar 2017 12:13:40 +0000 (13:13 +0100)
Requested-By: Corentin Labbe <clabbe.montjoie@gmail.com>
Package-Manager: Portage-2.3.3, Repoman-2.3.1

app-forensics/openscap/Manifest
app-forensics/openscap/openscap-1.2.13.ebuild [new file with mode: 0644]

index 5c0f590b58cd0ffb525b77225c7d09489cada80a..0f4f175bf19dd04e6d2f01aaf4bfef835d8c01b9 100644 (file)
@@ -2,4 +2,5 @@ DIST openscap-1.0.8.tar.gz 13576237 SHA256 5dc420eaf4202d09619abd9f6247ab6db4f7d
 DIST openscap-1.1.1.tar.gz 13722034 SHA256 510489099242f655bdff9f8f6641692ed0d035bf05f00f4ed8072b2e028aaf99 SHA512 86cd695098a749fb0ef29233a7bafde6d76379fd891cfc0bcc90e222e228a6968d3a2755a71a0115ed208408ee2f8316fbaf9714de9e3bb0c6a6535407a043b9 WHIRLPOOL e28464332f8e78519519766ef9e1cba509d54cc78cf2e23b1de043d9d68ff641426496b25a02a0da5c363ebd5470af705772b7ad81abad7308eaef8d89e9f568
 DIST openscap-1.2.0.tar.gz 14308605 SHA256 88329ebf23e7c7d063cdb5615fe1f68b18fb436a0df81307c5acc3b5963d7cec SHA512 1c290e0c20382c45da7d1c12ae69d33a71c04b34db39843805401b74f6bc392b10e2b401e0e8f4a62deef19d99254eadcc3b9702c2d5c12967ca9616f02cf2ed WHIRLPOOL 8ae5791dbfd5e4602f8deab12ae28bd93ed1d96f20314a968fb26d925382169e3a9cbf550f14c6c6c24ca86b0cd2268e3ebd713da3b8dad2f5cd55a403d74564
 DIST openscap-1.2.1.tar.gz 14338019 SHA256 6f7fdc579c4c27554cc3ec99a4f16381b719faa8c9b3ea09575d872a2c46eedb SHA512 e5bafe18708c76f223ec69a22da0b06b68546fd3eb9b370784ebff984308b60d02c89d6af24eefea87d16764fee760b70b5bf9eab2e88e7285e8f0d1d60232c9 WHIRLPOOL acd6cd094cf90ed1d9c7270104186ddebfed17ff0480b137653ee8e644aa031985960ad072c7b9d3880d8461ecfd6855cc842cba7665befdb9751c639538646c
+DIST openscap-1.2.13.tar.gz 15874074 SHA256 eeaa37a48b71b0cd455a94f40f01aea0572a846a9ea2722f7f5d2fbbc949ec5c SHA512 393b426f3278ab9438439df9a077b95b29bba66dfc2c799b7b40c2bf3980cf619aa1efc27225785ec780aa75926af6751b10fdb0b8d561c8056bf9a9a087792a WHIRLPOOL c49b039f5f05c333ddc0089d7aa0ee6d617af726ca8fbd68316ff6c6e3302eaff36cc527c71c9383934f4143e3c889817c1b5c0b2d783f4652be7b84045c3304
 DIST openscap-1.2.5.tar.gz 14513153 SHA256 7e0c56c108ff3042fd6a6650a808553de15e4dfc7ccc9fcdd6a839de827c47ed SHA512 abeafafeaedd60ca08b52b981f83d458bc972894fc466d7cff29170b578a023f314bd330d7c812d838e09cad567ddc5daafa7e46e4b9a0db76451114d98d17ca WHIRLPOOL 703c6467aa19384f6c50bf0cb465ad2a21c724892e8d7db1f1439992dff939933ff4c48d049bddfddd97599618aee0b27c51596e2f84778707257092273897db
diff --git a/app-forensics/openscap/openscap-1.2.13.ebuild b/app-forensics/openscap/openscap-1.2.13.ebuild
new file mode 100644 (file)
index 0000000..49ab47e
--- /dev/null
@@ -0,0 +1,138 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit bash-completion-r1 eutils multilib python-single-r1
+
+DESCRIPTION="Framework which enables integration with Security Content Automation Protocol"
+HOMEPAGE="http://www.open-scap.org/"
+SRC_URI="https://github.com/OpenSCAP/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="acl caps debug doc gconf ldap nss pcre perl python rpm selinux sce sql test xattr"
+RESTRICT="test"
+
+RDEPEND="!nss? ( dev-libs/libgcrypt:0 )
+       nss? ( dev-libs/nss )
+       acl? ( virtual/acl )
+       caps? ( sys-libs/libcap )
+       gconf? ( gnome-base/gconf )
+       ldap? ( net-nds/openldap )
+       pcre? ( dev-libs/libpcre )
+       rpm? ( >=app-arch/rpm-4.9 )
+       sql? ( dev-db/opendbx )
+       xattr? ( sys-apps/attr )
+       dev-libs/libpcre
+       dev-libs/libxml2
+       dev-libs/libxslt
+       net-misc/curl
+       ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+       doc? ( app-doc/doxygen )
+       perl? ( dev-lang/swig )
+       python? ( dev-lang/swig )
+       test? (
+               app-arch/unzip
+               dev-perl/XML-XPath
+               net-misc/ipcalc
+               sys-apps/grep )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+#      uncoment for debugging test
+#      sed -i 's,set -e,&;set -x,'     tests/API/XCCDF/unittests/test_remediate_simple.sh || die
+#      sed -i 's,^    bash,    LC_ALL=C bash,' tests/probes/process/test_probes_process.sh || die
+
+       sed -i 's/uname -p/uname -m/' tests/probes/uname/test_probes_uname.xml.sh || die
+
+       #probe runlevel for non-centos/redhat/fedora is not implemented
+       sed -i 's,.*runlevel_test.*,echo "runlevel test bypassed",' tests/mitre/test_mitre.sh || die
+       sed -i 's,probecheck "runlevel,probecheck "runlevellllll,' tests/probes/runlevel/test_probes_runlevel.sh || die
+
+       #According to comment of theses tests, we must modify it. For the moment disable it
+       sed -i 's,.*linux-def_inetlisteningservers_test,#&,' tests/mitre/test_mitre.sh || die
+       sed -i 's,.*ind-def_environmentvariable_test,#&,' tests/mitre/test_mitre.sh || die
+
+       # theses tests are hardcoded for checking hald process...,
+       # but no good solution for the moment, disabling them with a fake echo
+       # because encased in a if then
+#      sed -i 's,ha.d,/sbin/udevd --daemon,g' tests/mitre/unix-def_process_test.xml || die
+#      sed -i 's,ha.d,/sbin/udevd --daemon,g' tests/mitre/unix-def_process58_test.xml || die
+       sed -i 's,.*process_test.*,echo "process test bypassed",' tests/mitre/test_mitre.sh || die
+       sed -i 's,.*process58_test.*,echo "process58 test bypassed",' tests/mitre/test_mitre.sh || die
+
+       #This test fail
+       sed -i 's,.*generate report: xccdf,#&,' tests/API/XCCDF/unittests/all.sh ||     die
+
+       if ! use rpm ; then
+               sed -i 's,probe_rpminfo_req_deps_ok=yes,probe_rpminfo_req_deps_ok=no,' configure || die
+               sed -i 's,probe_rpminfo_opt_deps_ok=yes,probe_rpminfo_opt_deps_ok=no,' configure || die
+               sed -i 's,probe_rpmverify_req_deps_ok=yes,probe_rpmverify_req_deps_ok=no,' configure || die
+               sed -i 's,probe_rpmverify_opt_deps_ok=yes,probe_rpmverify_opt_deps_ok=no,' configure || die
+               sed -i 's,^probe_rpm.*_deps_missing=,&disabled_by_USE_flag,' configure || die
+               sed -i 's,.*rpm.*,#&,' tests/mitre/test_mitre.sh || die
+       fi
+       if ! use selinux ; then
+               einfo "Disabling SELinux probes"
+               sed -i 's,.*selinux.*,  echo "SELinux test bypassed",' tests/mitre/test_mitre.sh || die
+               #process58 need selinux
+               sed -i 's,.*process58,#&,' tests/mitre/test_mitre.sh || die
+       fi
+       if ! use ldap; then
+               einfo "Disabling LDAP probes"
+               sed -i 's,ldap.h,ldapp.h,g' configure || die
+       fi
+
+       epatch_user
+}
+
+src_configure() {
+       python_setup
+       local myconf
+       if use debug ; then
+               myconf+=" --enable-debug"
+       fi
+       if use python ; then
+               myconf+=" --enable-python"
+       else
+               myconf+=" --enable-python=no"
+       fi
+       if use perl ; then
+               myconf+=" --enable-perl"
+       fi
+       if use nss ; then
+               myconf+=" --with-crypto=nss3"
+       else
+               myconf+=" --with-crypto=gcrypt"
+       fi
+       if use sce ; then
+               myconf+=" --enable-sce"
+       else
+               myconf+=" --enable-sce=no"
+       fi
+       econf ${myconf}
+}
+
+src_compile() {
+       emake
+       if use doc ; then
+               cd docs && doxygen Doxyfile || die
+       fi
+}
+
+src_install() {
+       emake install DESTDIR="${D}"
+       prune_libtool_files --all
+       if use doc ; then
+               dohtml -r docs/html/.
+               dodoc -r docs/examples/.
+       fi
+       dobashcomp "${D}"/etc/bash_completion.d/oscap
+       rm -rf "${D}"/etc/bash_completion.d || die
+}