sys-apps/epoch: fix #607214 missing default config file
authorAlice Ferrazzi <alicef@gentoo.org>
Thu, 26 Jan 2017 17:52:12 +0000 (02:52 +0900)
committerAlice Ferrazzi <alicef@gentoo.org>
Thu, 26 Jan 2017 17:53:14 +0000 (02:53 +0900)
Package-Manager: portage-2.3.3

sys-apps/epoch/epoch-1.2.1.ebuild
sys-apps/epoch/epoch-1.2.2.ebuild
sys-apps/epoch/epoch-1.3.0.ebuild
sys-apps/epoch/files/epoch-1.0-epoch.conf [new file with mode: 0644]

index af7b6bbbfaf7edc5d3c0fd7126dccf1f3a8c5b30..1978a7197d5aa55570aec61f362cc731417d6ccc 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -55,7 +55,7 @@ src_install() {
        newepochins sbin
 
        insinto /etc/epoch/
-       newins "${FILESDIR}"/${PN}-1.0_rc1-epoch.conf epoch.conf
+       newins "${FILESDIR}"/${PN}-1.0-epoch.conf epoch.conf
 }
 
 pkg_postinst() {
index 6057021a67034ff9df0fbedf759bcce1d3e06d58..34858562e1746dd366eb96f2c42c0334c137c6dc 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -55,7 +55,7 @@ src_install() {
        newepochins sbin
 
        insinto /etc/epoch/
-       newins "${FILESDIR}"/${PN}-1.0_rc1-epoch.conf epoch.conf
+       newins "${FILESDIR}"/${PN}-1.0-epoch.conf epoch.conf
 }
 
 pkg_postinst() {
index 70f783dd539e4906cedf40bdfc109b5c6b9ec3e6..e41840247b1b2343987f04ee439d365f0cb15e4b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -56,7 +56,7 @@ src_install() {
        newepochins sbin
 
        insinto /etc/epoch/
-       newins "${FILESDIR}"/${PN}-1.0_rc1-epoch.conf epoch.conf
+       newins "${FILESDIR}"/${PN}-1.0-epoch.conf epoch.conf
 }
 
 pkg_postinst() {
diff --git a/sys-apps/epoch/files/epoch-1.0-epoch.conf b/sys-apps/epoch/files/epoch-1.0-epoch.conf
new file mode 100644 (file)
index 0000000..e0550d4
--- /dev/null
@@ -0,0 +1,77 @@
+BootBannerText=Welcome!
+BootBannerColor=RED
+
+Hostname=FILE /etc/hostname
+DefaultRunlevel=boot
+EnableLogging=true
+MountVirtual=procfs sysfs devpts+ devshm+
+
+ObjectID=mountrun
+       ObjectDescription=Mounting /run
+       ObjectStartCommand=mount /run
+       ObjectStartPriority=1
+       ObjectStopPriority=0
+       ObjectEnabled=true
+       ObjectOptions=RAWDESCRIPTION
+       ObjectRunlevels=boot
+
+ObjectID=mounttmp
+       ObjectDescription=Mounting /tmp
+       ObjectStartCommand=mount /tmp
+       ObjectStartPriority=1
+       ObjectStopPriority=0
+       ObjectEnabled=true
+       ObjectOptions=RAWDESCRIPTION
+       ObjectRunlevels=boot
+
+ObjectID=rwfs
+       ObjectDescription=read-write support on /
+       ObjectStartCommand=/bin/mount -o remount,rw /
+       ObjectStopCommand=/bin/mount -o remount,ro /
+       ObjectStartPriority=2
+       ObjectStopPriority=5
+       ObjectEnabled=true
+       ObjectRunlevels=boot
+
+ObjectID=getty1
+       ObjectDescription=agetty on /dev/tty1
+       ObjectStartCommand=agetty --noclear tty1 &
+       ObjectStopCommand=NONE
+       ObjectStartPriority=3
+       ObjectStopPriority=0
+       ObjectEnabled=true
+       ObjectOptions=SERVICE AUTORESTART
+       ObjectRunlevels=boot
+
+ObjectID=extrafs
+       ObjectDescription=extra filesystems and swaps
+       ObjectStartCommand=mount -a && swapon -a
+       ObjectStopCommand=swapoff -a && umount -a -r -t nodevtmpfs,notmpfs,nosysfs,noproc
+       ObjectStartPriority=4
+       ObjectStopPriority=4
+       ObjectEnabled=true
+       ObjectRunlevels=boot
+
+ObjectID=killall5_soft
+       ObjectDescription=Terminating all processes
+       ObjectStopCommand=killall5 -15 && sleep 1
+       ObjectStartPriority=0
+       ObjectStopPriority=1
+       ObjectEnabled=true
+       ObjectOptions=HALTONLY RAWDESCRIPTION
+       
+ObjectID=sync
+       ObjectDescription=Syncing
+       ObjectStopCommand=/bin/sync
+       ObjectStartPriority=0
+       ObjectStopPriority=2
+       ObjectEnabled=true
+       ObjectOptions=HALTONLY RAWDESCRIPTION
+
+ObjectID=killall5
+       ObjectDescription=Killing all processes
+       ObjectStopCommand=killall5 -9 && sleep 1
+       ObjectStartPriority=0
+       ObjectStopPriority=3
+       ObjectEnabled=true
+       ObjectOptions=HALTONLY RAWDESCRIPTION