media-sound/substract_wave: bump EAPI and drop eutils
authorAaron Bauman <bman@gentoo.org>
Mon, 28 May 2018 00:33:41 +0000 (20:33 -0400)
committerAaron Bauman <bman@gentoo.org>
Mon, 28 May 2018 23:01:55 +0000 (19:01 -0400)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

media-sound/substract_wave/substract_wave-0.3-r1.ebuild

index cd3e2c907b7413e08af1b8199d1e4120412dac57..3ddefd3e9e07abe1998474e318b15e8d6f21757f 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=2
-inherit eutils toolchain-funcs
+EAPI=7
+inherit toolchain-funcs
 
 DESCRIPTION="substracts 2 mono wave files from each other by a factor specified on the command line"
 HOMEPAGE="http://panteltje.com/panteltje/dvd/"
@@ -13,17 +13,14 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE=""
 
-src_prepare() {
-       epatch "${FILESDIR}"/${P}-Makefile.patch \
-               "${FILESDIR}"/${P}-overflow.patch
-}
+PATCHES=(
+       "${FILESDIR}/${P}-Makefile.patch"
+       "${FILESDIR}/${P}-overflow.patch"
+)
+
+DOCS=( CHANGES mono-stereo.txt README )
 
 src_compile() {
        tc-export CC
        emake || die "emake failed"
 }
-
-src_install() {
-       emake DESTDIR="${D}" install || die "emake install failed"
-       dodoc CHANGES mono-stereo.txt README
-}