dev-python/clint: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 14:24:20 +0000 (15:24 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 14:50:19 +0000 (15:50 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/clint/clint-0.5.1.ebuild [deleted file]

diff --git a/dev-python/clint/clint-0.5.1.ebuild b/dev-python/clint/clint-0.5.1.ebuild
deleted file mode 100644 (file)
index f410d95..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Python Command-line Application Tools"
-HOMEPAGE="https://github.com/kennethreitz/clint"
-SRC_URI="https://github.com/kennethreitz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-RDEPEND="dev-python/args[${PYTHON_USEDEP}]"
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       py.test || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       if use examples; then
-               insinto /usr/share/doc/${PF}
-               doins -r examples
-       fi
-
-       distutils-r1_python_install_all
-}