PHP herd takes over maintainance, cleanup ebuilds.
authorLuca Longinotti <chtekk@gentoo.org>
Fri, 1 Dec 2006 16:31:25 +0000 (16:31 +0000)
committerLuca Longinotti <chtekk@gentoo.org>
Fri, 1 Dec 2006 16:31:25 +0000 (16:31 +0000)
Package-Manager: portage-2.1.2_rc2-r2

dev-db/libiodbc/ChangeLog
dev-db/libiodbc/libiodbc-3.51.2.ebuild
dev-db/libiodbc/libiodbc-3.52.4.ebuild
dev-db/libiodbc/metadata.xml

index 7ee0e660bfad26ce93498e5f58a8a3a55e6ba1ad..2d31ac72f4d9c732baf7678aa86817badcae9ca2 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for dev-db/libiodbc
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libiodbc/ChangeLog,v 1.21 2006/10/30 18:04:54 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libiodbc/ChangeLog,v 1.22 2006/12/01 16:31:25 chtekk Exp $
+
+  01 Dec 2006; Luca Longinotti <chtekk@gentoo.org> metadata.xml,
+  -libiodbc-3.51.1-r2.ebuild, libiodbc-3.51.2.ebuild,
+  libiodbc-3.52.4.ebuild:
+  PHP herd takes over maintainance, cleanup ebuilds.
 
   30 Oct 2006; Gustavo Zacarias <gustavoz@gentoo.org>
   libiodbc-3.52.4.ebuild:
index 7f322f88e3f32948ebf0a4f4969a5e6a80e35a19..d1cad1d232d1ba67861bac877f5da55deb1026fc 100644 (file)
@@ -1,44 +1,40 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libiodbc/libiodbc-3.51.2.ebuild,v 1.19 2006/01/21 23:07:08 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libiodbc/libiodbc-3.51.2.ebuild,v 1.20 2006/12/01 16:31:25 chtekk Exp $
 
 inherit eutils
 
-DESCRIPTION="ODBC Interface for Linux"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86"
+
+DESCRIPTION="ODBC Interface for Linux."
 HOMEPAGE="http://www.iodbc.org/"
 SRC_URI="http://www.iodbc.org/downloads/iODBC/${P}.tar.gz"
-
 LICENSE="LGPL-2 BSD"
 SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86"
 IUSE="gtk"
 
 DEPEND=">=sys-libs/readline-4.1
-       >=sys-libs/ncurses-5.2
-       gtk? ( >=x11-libs/gtk+-1.2.10 )"
+               >=sys-libs/ncurses-5.2
+               gtk? ( >=x11-libs/gtk+-1.2.10 )"
+RDEPEND="${DEPEND}"
 
 src_unpack() {
        unpack ${A}
        cd "${S}"
-       epatch "${FILESDIR}"/libiodbc-3.51.2_install_symlink.diff
+       epatch "${FILESDIR}/${P}_install_symlink.diff"
 }
 
 src_compile() {
-       local myconf=""
-       use gtk \
-               && myconf="${myconf} --enable-gui=yes" \
-               || myconf="${myconf} --disable-gui"
-
        econf \
                --with-layout=gentoo \
-               ${myconf} || die
-       make || die
+               $(use_enable gtk gui yes) \
+               || die "econf failed"
+
+       emake -j1 || die "emake failed"
 }
 
 src_install() {
-       make DESTDIR="${D}" install || die
+       emake -j1 DESTDIR="${D}" install || die "emake install failed"
 
        dodoc AUTHORS ChangeLog NEWS README*
-       #find doc/ -name "Makefile*" -exec rm '{}' \;
-       #dohtml doc/*
 }
index d8726b9f60b7b3edd4cdb0fc09d03e547227e78b..59394d0b043a3e48b85eaf400d286d4ad1a6e1a1 100644 (file)
@@ -1,24 +1,23 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libiodbc/libiodbc-3.52.4.ebuild,v 1.5 2006/11/26 23:54:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libiodbc/libiodbc-3.52.4.ebuild,v 1.6 2006/12/01 16:31:25 chtekk Exp $
 
-#inherit eutils autotools
+KEYWORDS="~alpha ~amd64 arm ~hppa ia64 ~ppc ~ppc64 s390 sh sparc x86"
 
-DESCRIPTION="ODBC Interface for Linux"
+DESCRIPTION="ODBC Interface for Linux."
 HOMEPAGE="http://www.iodbc.org/"
 SRC_URI="http://www.iodbc.org/downloads/iODBC/${P}.tar.gz"
-
 LICENSE="LGPL-2 BSD"
 SLOT="0"
-KEYWORDS="~alpha ~amd64 arm ~hppa ia64 ~ppc ~ppc64 s390 sh sparc x86"
 IUSE="gtk"
 
 # upstream does weird stuff in their configure
 RESTRICT="confcache"
 
 DEPEND=">=sys-libs/readline-4.1
-       >=sys-libs/ncurses-5.2
-       gtk? ( >=x11-libs/gtk+-1.2.10 )"
+               >=sys-libs/ncurses-5.2
+               gtk? ( >=x11-libs/gtk+-1.2.10 )"
+RDEPEND="${DEPEND}"
 
 src_unpack() {
        unpack ${A}
@@ -34,16 +33,13 @@ src_compile() {
        econf \
                --with-layout=gentoo \
                $(use_enable gtk gui yes) \
-               || die
-       # not parallel safe
-       emake -j1 || die
+               || die "econf failed"
+
+       emake -j1 || die "emake failed"
 }
 
 src_install() {
-       # not parallel safe
-       emake -j1 DESTDIR="${D}" install || die
+       emake -j1 DESTDIR="${D}" install || die "emake install failed"
 
        dodoc AUTHORS ChangeLog NEWS README*
-       #find doc/ -name "Makefile*" -exec rm '{}' \;
-       #dohtml doc/*
 }
index d9cd2cad66c265328acb729dbfc77f2d0493d0f8..fd3dbe39fa64544d93653545354397b4f1e1e79c 100644 (file)
@@ -1,7 +1,5 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<maintainer>
-<email>maintainer-needed@gentoo.org</email>
-</maintainer>
+       <herd>php</herd>
 </pkgmetadata>