dev-util/coccinelle: version bump to 1.0.6
authorTim Harder <radhermit@gentoo.org>
Fri, 9 Dec 2016 06:58:00 +0000 (01:58 -0500)
committerTim Harder <radhermit@gentoo.org>
Fri, 9 Dec 2016 06:58:00 +0000 (01:58 -0500)
dev-util/coccinelle/Manifest
dev-util/coccinelle/coccinelle-1.0.6.ebuild [new file with mode: 0644]

index 7937f306e24f1ce6ae9768b5a9c7b1f92765c923..3e5ca3a1b1efe4d2ab92ee2647a1785a78520cf9 100644 (file)
@@ -1 +1,2 @@
 DIST coccinelle-1.0.5.tgz 5660596 SHA256 5efb093b538145b7526a06946c09c7caaa715006658af2049faa8739f459743b SHA512 0fee450554abc40feac9e745a252c1679f8016c82f04236e642e32e129618a950bb9657f1c447d62543289e95bbd4b1a8b0c6030373025c32a37068f82d30678 WHIRLPOOL 33ec9789d93f6cd35eda37f0647d3e3f3f53898fccc2df68aa30cec50ce82b4d392d84a0c97708cdf301b2f076cce1942b5d4a51dffb0bd177eb9dee460d3e6f
+DIST coccinelle-1.0.6.tgz 6684278 SHA256 8452ed265c209dae99cbb33b67bc7912e72f8bca1e24f33f1a88ba3d7985e909 SHA512 b667762ddf5ad30b126e93572cd8a8b3ffc21a790cd9d6df586e421c5db0a8d049af9587c6e5cb8f7a13f2c090ab2a9cca59ecba69069f9d3fe67b6f75dfe539 WHIRLPOOL 3a47b3d2f844e4ee38972566971db261c58cb26e73ccf1187b9b5bda0561327c6bea9a48e6f8fc3db285b5cef8e011feb7d6a6fff09754338dbf103fb1900f3d
diff --git a/dev-util/coccinelle/coccinelle-1.0.6.ebuild b/dev-util/coccinelle/coccinelle-1.0.6.ebuild
new file mode 100644 (file)
index 0000000..70d5c91
--- /dev/null
@@ -0,0 +1,125 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit multilib eutils python-single-r1 bash-completion-r1 elisp-common
+
+MY_P="${P/_/-}"
+DESCRIPTION="Program matching and transformation engine"
+HOMEPAGE="http://coccinelle.lip6.fr/"
+SRC_URI="http://coccinelle.lip6.fr/distrib/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc emacs ocaml +ocamlopt pcre python test vim-syntax"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# ocaml enables ocaml scripting (uses findlib)
+CDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
+       dev-ml/sexplib:=[ocamlopt?]
+       dev-ml/menhir:=[ocamlopt?]
+       dev-ml/camlp4:=[ocamlopt?]
+       dev-ml/parmap:=[ocamlopt?]
+       emacs? ( virtual/emacs )
+       ocaml? ( dev-ml/findlib:= )
+       pcre? ( dev-ml/pcre-ocaml:=[ocamlopt?] )
+       python? ( ${PYTHON_DEPS} )"
+
+RDEPEND="${CDEPEND}
+       vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+
+# dev-texlive/texlive-fontsextra contains 'ifsym.sty'
+DEPEND="${CDEPEND}
+       virtual/pkgconfig
+       doc? (
+               virtual/latex-base
+               dev-texlive/texlive-latexextra
+               dev-texlive/texlive-fontsextra
+       )"
+
+DOCS=( authors.txt bugs.txt changes.txt credits.txt readme.txt )
+
+S=${WORKDIR}/${MY_P}
+
+SITEFILE=50coccinelle-gentoo.el
+
+pkg_setup() {
+       use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       default
+
+       if use python ; then
+               # fix python install location
+               sed -e "s:\$(LIBDIR)/python:$(python_get_sitedir):" \
+                       -i Makefile || die
+       fi
+}
+
+src_configure() {
+       econf \
+               $(use_enable python) \
+               $(use_enable ocaml) \
+               $(use_enable pcre) \
+               $(use_enable pcre pcre-syntax) \
+               $(use_enable ocamlopt opt)
+}
+
+src_compile() {
+       emake depend
+
+       if use ocamlopt ; then
+               emake all.opt
+       else
+               emake TARGET_SPATCH=byte-only all-dev
+       fi
+
+       if use doc ; then
+               VARTEXFONTS="${T}"/fonts emake docs
+       fi
+
+       if use emacs ; then
+               elisp-compile editors/emacs/cocci.el || die
+       fi
+}
+
+src_test() {
+       emake check
+       use python && emake pycocci-check
+}
+
+src_install() {
+       default
+
+       use doc && dodoc docs/manual/*.pdf
+       newbashcomp scripts/spatch.bash_completion spatch
+
+       if use emacs ; then
+               elisp-install ${PN} editors/emacs/*
+               elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+       fi
+
+       if use vim-syntax ; then
+               newdoc editors/vim/README README-vim
+               rm editors/vim/README || die
+               insinto /usr/share/vim/vimfiles
+               doins -r editors/vim/*
+       fi
+
+       use python && python_optimize
+
+       export STRIP_MASK='*/coccinelle/spatch'
+}
+
+pkg_postinst() {
+       use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+       use emacs && elisp-site-regen
+}