dev-python/iocapture: python3_6 added
authorAndrey Grozin <grozin@gentoo.org>
Tue, 28 Feb 2017 12:52:31 +0000 (19:52 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Tue, 28 Feb 2017 12:53:44 +0000 (19:53 +0700)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-python/iocapture/iocapture-0.1.2-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/iocapture/iocapture-0.1.2-r1.ebuild b/dev-python/iocapture/iocapture-0.1.2-r1.ebuild
new file mode 100644 (file)
index 0000000..dfbf4f7
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: 521a8c56754f34ba6918b8bc4426f0b679be2186 $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Capture stdout,stderr easily"
+HOMEPAGE="https://pypi.python.org/pypi/iocapture/"
+SRC_URI="https://github.com/oinume/iocapture/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+LICENSE="MIT"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+               ${RDEPEND}
+       )"
+
+python_test() {
+       py.test || die "Tests fail with ${EPYTHON}"
+}