www-servers/tomcat: fixed some qa issues
authorMiroslav Šulc <fordfrog@gentoo.org>
Fri, 22 Nov 2019 10:52:48 +0000 (11:52 +0100)
committerMiroslav Šulc <fordfrog@gentoo.org>
Fri, 22 Nov 2019 10:53:09 +0000 (11:53 +0100)
1) removed \!<dev-java/tomcat-native-1.1.24 restriction
   (not in the tree anymore)
2) fixed dependency on dev-java/tomcat-servlet-api
   in 9.0.7 to include revisions

Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
www-servers/tomcat/tomcat-7.0.96.ebuild
www-servers/tomcat/tomcat-8.5.46.ebuild
www-servers/tomcat/tomcat-8.5.47.ebuild
www-servers/tomcat/tomcat-9.0.27.ebuild
www-servers/tomcat/tomcat-9.0.7.ebuild

index cd40b029523af42f2189937d1bf0f44dd62b1ab5..443dd981a8d0cc9fd06fbe8c7f18f8f792e893df 100644 (file)
@@ -26,8 +26,7 @@ SAPI_SLOT="3.0"
 COMMON_DEP="dev-java/eclipse-ecj:${ECJ_SLOT}
        dev-java/tomcat-servlet-api:${SAPI_SLOT}"
 RDEPEND="${COMMON_DEP}
-       virtual/jre
-       !<dev-java/tomcat-native-1.1.24"
+       virtual/jre"
 DEPEND="${COMMON_DEP}
        virtual/jdk:1.8
        test? ( dev-java/ant-junit:0 )"
index c6e5e958e89ed2ea25d4eca432de296af310b104..0437014fa017fe4aafe56465699dff1829a2af42 100644 (file)
@@ -26,7 +26,6 @@ SAPI_SLOT="3.1"
 COMMON_DEP="dev-java/eclipse-ecj:${ECJ_SLOT}
        >=dev-java/tomcat-servlet-api-${SLOT}:${SAPI_SLOT}"
 RDEPEND="${COMMON_DEP}
-       !<dev-java/tomcat-native-1.1.24
        >=virtual/jre-1.7"
 DEPEND="${COMMON_DEP}
        app-admin/pwgen
index 9b5c64f0de13a9cf9137f2e7013666a81293dcbd..d34cd3a9d3cbec1efd19e3e657748a0a87af2d5a 100644 (file)
@@ -26,7 +26,6 @@ SAPI_SLOT="3.1"
 COMMON_DEP="dev-java/eclipse-ecj:${ECJ_SLOT}
        >=dev-java/tomcat-servlet-api-${SLOT}:${SAPI_SLOT}"
 RDEPEND="${COMMON_DEP}
-       !<dev-java/tomcat-native-1.1.24
        >=virtual/jre-1.8"
 DEPEND="${COMMON_DEP}
        app-admin/pwgen
index 6f5e0ef52f6d3c237404ab119a73fc30001e7343..182cad35d13c1a5d31be77c2bd5a43703aa4ef80 100644 (file)
@@ -36,7 +36,6 @@ COMMON_DEP="dev-java/eclipse-ecj:${ECJ_SLOT}
        dev-java/tomcat-servlet-api:${SAPI_SLOT}
        dev-java/wsdl4j:0"
 RDEPEND="${COMMON_DEP}
-       !<dev-java/tomcat-native-1.1.24
        >=virtual/jre-11"
 DEPEND="${COMMON_DEP}
        app-admin/pwgen
index 7a404767db95afebbfe8873edd458b3f039917cc..967fffcd751ec8cef70c03d1385b65a2816ad5ca 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -24,9 +24,8 @@ ECJ_SLOT="4.5"
 SAPI_SLOT="4.0"
 
 COMMON_DEP="dev-java/eclipse-ecj:${ECJ_SLOT}
-       =dev-java/tomcat-servlet-api-${PV}:${SAPI_SLOT}"
+       ~dev-java/tomcat-servlet-api-${PV}:${SAPI_SLOT}"
 RDEPEND="${COMMON_DEP}
-       !<dev-java/tomcat-native-1.1.24
        >=virtual/jre-1.8"
 DEPEND="${COMMON_DEP}
        app-admin/pwgen