app-i18n/man-pages-de: bump to 2.5
authorVirgil Dupras <vdupras@gentoo.org>
Wed, 17 Oct 2018 21:37:37 +0000 (17:37 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Wed, 17 Oct 2018 21:38:20 +0000 (17:38 -0400)
Reported-By: Markus Oehme
Closes: https://bugs.gentoo.org/654858
Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

app-i18n/man-pages-de/Manifest
app-i18n/man-pages-de/man-pages-de-2.5.ebuild [new file with mode: 0644]

index 886fc7d44dcc01ee363155980cc00d14e5df14b8..8871e42cadab03b6a267b2c0f9c1bfdae7c707a7 100644 (file)
@@ -1,3 +1,4 @@
 DIST manpages-de-1.15.tar.xz 1529576 BLAKE2B 600d9c186ffa46fd1db110c3889abc44bb6ccb6847ed8385c461c7fa696f5a9e8a65233d1290ae9d1e9eb26694e8769aa35983f07205a0e7e57c9b0c14c7d7bc SHA512 d1f1b9f60c4713d6be650e21b7664ff594dbd542b53148c00d1a2269413d39615dd76be4c4095eeb72e2598b94af134ca5d128b85d9520a1ac404364b8a53948
 DIST manpages-de-1.21.tar.xz 1585600 BLAKE2B f2364e0b5fc1ca8ce8f5eb7fa5987d1bc68b1f8f2c1a26240d5cabd03eb5bb094f0d63274c7208059a766498f5f20ca7ccab72a9d4847057aae3b7d6697018e7 SHA512 24cc36e8e9c2efb8cd2a0c374a3f5da96f6645a306082cc28aae5933081f7de24bac03652f690a2becd32a23a93c17ddd9029190c299dda95eeb25f49b327fac
 DIST manpages-de-2.3.tar.xz 7016372 BLAKE2B 3b89049d11bfd539e9114de38198f610145972068c9cec1da1b6398fb1d3e846b112ca0336891c1782a6fb142f397ac472ad78be0596503377318bfe65ec68d2 SHA512 abc3574c4a315d86b4fcccb25d617851c1ff43844fc7b1b92d7849a098280a96ab73d4986047fe6bb18e8f11d391182370eff9db476e0dd2021d0725b4e945eb
+DIST manpages-de-v2.5.tar.bz2 8744190 BLAKE2B 06b9f970e652892edda6079bd4b912b2272652b5060a0d7a7c3dcd074f2ac71730800a077b7aa4d5175fb44723a60642e39c1bf81ecc731dcadb0ab703461df9 SHA512 3bf5f794ec9a1036f0fdcbea6afc03fd845f42b83c928116e4f47980060b3dcedfb25cd4330a60cc3da7f573d73a50e61ccb6a681979fcc6bfb63b882de1fd20
diff --git a/app-i18n/man-pages-de/man-pages-de-2.5.ebuild b/app-i18n/man-pages-de/man-pages-de-2.5.ebuild
new file mode 100644 (file)
index 0000000..d8f5068
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+MY_P="${PN/-/}-v${PV}"
+
+DESCRIPTION="A somewhat comprehensive collection of Linux german man page translations"
+HOMEPAGE="https://salsa.debian.org/manpages-de-team/manpages-de"
+SRC_URI="https://salsa.debian.org/manpages-de-team/manpages-de/-/archive/v${PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3+ man-pages GPL-2+ GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/man"
+DEPEND="app-text/po4a"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+       default
+
+       # sys-apps/shadow has it's own translated man-page for this
+       rm "${S}/upstream/primary/man1/groups.1" || die
+       rm "${S}/po/primary/man1/groups.1.po" || die
+}
+
+src_prepare() {
+       default
+
+       # Use the same compression as every other manpage
+       local PORTAGE_COMPRESS_LOCAL=${PORTAGE_COMPRESS-bzip2}
+       if [[ ${PORTAGE_COMPRESS+set} == "set" ]] ; then
+               PORTAGE_COMPRESS_LOCAL="#"
+       fi
+       if [[ ${PORTAGE_COMPRESS_FLAGS+set} != "set" ]] ; then
+               case ${PORTAGE_COMPRESS_LOCAL} in
+                       bzip2|gzip)  local PORTAGE_COMPRESS_FLAGS_LOCAL="-9"
+                       ;;
+               esac
+       fi
+       sed -i -e "s/gzip --best/${PORTAGE_COMPRESS_LOCAL} ${PORTAGE_COMPRESS_FLAGS_LOCAL}/"\
+               po/Makefile.in || die
+       eautoreconf
+}
+
+src_compile() { :; }
+
+src_install() {
+       emake mandir="${ED}"/usr/share/man install
+       dodoc CHANGES.md README.md
+}