use _E_CROSS_HEADERS_ONLY in USE rather than as an env var
authorMike Frysinger <vapier@gentoo.org>
Wed, 15 Mar 2006 01:48:51 +0000 (01:48 +0000)
committerMike Frysinger <vapier@gentoo.org>
Wed, 15 Mar 2006 01:48:51 +0000 (01:48 +0000)
Package-Manager: portage-2.1_pre6-r2

sys-libs/glibc/glibc-2.3.6-r1.ebuild
sys-libs/glibc/glibc-2.3.6-r2.ebuild
sys-libs/glibc/glibc-2.3.6-r3.ebuild
sys-libs/glibc/glibc-2.4.ebuild
sys-libs/uclibc/uclibc-0.9.27-r1.ebuild
sys-libs/uclibc/uclibc-0.9.28.ebuild

index 38d0c31ffd1b22bd413e66a35978665e49b3750f..ca07155b50a9efa2c622da6808feb28a06e0eac9 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r1.ebuild,v 1.16 2006/01/26 02:17:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r1.ebuild,v 1.17 2006/03/15 01:48:51 vapier Exp $
 
 # Here's how the cross-compile logic breaks down ...
 #  CTARGET - machine that will target the binaries
@@ -67,8 +67,7 @@ is_crosscompile() {
        [[ ${CHOST} != ${CTARGET} ]]
 }
 just_headers() {
-       [[ -z ${_E_CROSS_HEADERS_ONLY} ]] && return 1
-       is_crosscompile
+       is_crosscompile && has _E_CROSS_HEADERS_ONLY ${USE}
 }
 
 GLIBC_RELEASE_VER=$(get_version_component_range 1-3)
index 922126e33c675ac7a58448ceccbd5653f0504487..2becf048477a131cf416b4e8c88f1d398d401927 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r2.ebuild,v 1.13 2006/01/26 02:17:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r2.ebuild,v 1.14 2006/03/15 01:48:51 vapier Exp $
 
 # TODO:
 #  - fix warning from glibc build system:
@@ -75,8 +75,7 @@ is_crosscompile() {
        [[ ${CHOST} != ${CTARGET} ]]
 }
 just_headers() {
-       [[ -z ${_E_CROSS_HEADERS_ONLY} ]] && return 1
-       is_crosscompile
+       is_crosscompile && has _E_CROSS_HEADERS_ONLY ${USE}
 }
 
 GLIBC_RELEASE_VER=$(get_version_component_range 1-3)
index 0304dc0c0d1411e871392ca001af6cc6c13c14bc..8ae65bd63e307be857339318e009139c0f74584d 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r3.ebuild,v 1.4 2006/02/27 15:46:50 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r3.ebuild,v 1.5 2006/03/15 01:48:51 vapier Exp $
 
 # TODO:
 #  - fix warning from glibc build system:
@@ -75,8 +75,7 @@ is_crosscompile() {
        [[ ${CHOST} != ${CTARGET} ]]
 }
 just_headers() {
-       [[ -z ${_E_CROSS_HEADERS_ONLY} ]] && return 1
-       is_crosscompile
+       is_crosscompile && has _E_CROSS_HEADERS_ONLY ${USE}
 }
 
 GLIBC_RELEASE_VER=$(get_version_component_range 1-3)
index 55fcd4c8318450f2bb9040e1a482b0b7032c07a3..376755bcf64a75d0cc22592659fd3390db2b1ff8 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.4.ebuild,v 1.7 2006/03/12 17:57:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.4.ebuild,v 1.8 2006/03/15 01:48:51 vapier Exp $
 
 # TODO:
 #  - fix warning from glibc build system:
@@ -74,8 +74,7 @@ is_crosscompile() {
        [[ ${CHOST} != ${CTARGET} ]]
 }
 just_headers() {
-       [[ -z ${_E_CROSS_HEADERS_ONLY} ]] && return 1
-       is_crosscompile
+       is_crosscompile && has _E_CROSS_HEADERS_ONLY ${USE}
 }
 
 GLIBC_RELEASE_VER=$(get_version_component_range 1-3)
index ccde23b5b0005a7837e8229b0dc72a0dc4baf2c4..c11f7cb67ccc1d493ed5426e95fa62c32dde8e7c 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild,v 1.15 2005/12/29 12:30:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild,v 1.16 2006/03/15 01:47:04 vapier Exp $
 
 inherit eutils flag-o-matic toolchain-funcs
 
@@ -77,9 +77,7 @@ alt_rprefix() {
        fi
 }
 just_headers() {
-       [[ -z ${_E_CROSS_HEADERS_ONLY} ]] && return 1
-       [[ ${CHOST} == ${CTARGET} ]] && return 1
-       return 0
+       has _E_CROSS_HEADERS_ONLY ${USE} && [[ ${CHOST} != ${CTARGET} ]]
 }
 
 pkg_setup() {
index e94a93851beef002e93b81e52014104c6c9c42ab..0cfa82e3795d6421d336c4aed9e554a3316a9bad 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.ebuild,v 1.20 2006/03/11 03:23:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.ebuild,v 1.21 2006/03/15 01:47:04 vapier Exp $
 
 #ESVN_REPO_URI="svn://uclibc.org/trunk/uClibc"
 #inherit subversion
@@ -75,9 +75,7 @@ alt_rprefix() {
        fi
 }
 just_headers() {
-       [[ -z ${_E_CROSS_HEADERS_ONLY} ]] && return 1
-       [[ ${CHOST} == ${CTARGET} ]] && return 1
-       return 0
+       has _E_CROSS_HEADERS_ONLY ${USE} && [[ ${CHOST} != ${CTARGET} ]]
 }
 
 pkg_setup() {