dev-ml/llvm-ocaml: Reorder ebuild vars in 9+
authorMichał Górny <mgorny@gentoo.org>
Sat, 21 Sep 2019 08:32:43 +0000 (10:32 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 21 Sep 2019 09:15:26 +0000 (11:15 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild
dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.9999.ebuild
dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.ebuild

index 3fd5dbb40b8e840fae4ba9b7be1aae05f22298d3..5fb5269eb058496abd9316999601e63e37263af2 100644 (file)
@@ -28,6 +28,7 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0/${PV}"
 KEYWORDS=""
 IUSE="debug test ${ALL_LLVM_TARGETS[*]}"
+REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
 RESTRICT="!test? ( test )"
 
 RDEPEND="
@@ -44,8 +45,6 @@ BDEPEND="
        !!<dev-python/configparser-3.3.0.2
        ${PYTHON_DEPS}"
 
-REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
-
 # least intrusive of all
 CMAKE_BUILD_TYPE=RelWithDebInfo
 
index fad71890f1af865e2861dd233ee823d3d6ce8695..ea47038cb4437095d1773bba4f5e13aeb1e671e4 100644 (file)
@@ -27,6 +27,7 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0/${PV}"
 KEYWORDS=""
 IUSE="debug test ${ALL_LLVM_TARGETS[*]}"
+REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
 RESTRICT="!test? ( test )"
 
 RDEPEND="
@@ -43,8 +44,6 @@ BDEPEND="
        !!<dev-python/configparser-3.3.0.2
        ${PYTHON_DEPS}"
 
-REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
-
 # least intrusive of all
 CMAKE_BUILD_TYPE=RelWithDebInfo
 
index 9c9c5f6b2440a41fd056e76351914e19c92b9812..44c293f604cc7e4e027527704abce0eacae1afba 100644 (file)
@@ -14,6 +14,7 @@ MY_P=llvm-${PV/_/}.src
 DESCRIPTION="OCaml bindings for LLVM"
 HOMEPAGE="https://llvm.org/"
 SRC_URI="https://releases.llvm.org/${PV}/${MY_P}.tar.xz"
+S=${WORKDIR}/${MY_P}
 
 # Keep in sync with sys-devel/llvm
 ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430
@@ -25,6 +26,7 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0/${PV}"
 KEYWORDS="~amd64 ~arm ~x86"
 IUSE="debug test ${ALL_LLVM_TARGETS[*]}"
+REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
 RESTRICT="!test? ( test )"
 
 RDEPEND="
@@ -41,10 +43,6 @@ BDEPEND="
        !!<dev-python/configparser-3.3.0.2
        ${PYTHON_DEPS}"
 
-REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
-
-S=${WORKDIR}/${MY_P}
-
 # least intrusive of all
 CMAKE_BUILD_TYPE=RelWithDebInfo