app-doc/cppman: cleanup, fix DOCS location
authorneeshy <neeshy@tfwno.gf>
Sat, 28 Mar 2020 20:06:52 +0000 (16:06 -0400)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 5 Apr 2020 07:17:54 +0000 (10:17 +0300)
Signed-off-by: Nima Sadeghi <neeshy@tfwno.gf>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-doc/cppman/cppman-0.4.8-r2.ebuild [moved from app-doc/cppman/cppman-0.4.8-r1.ebuild with 59% similarity]
app-doc/cppman/cppman-0.4.9.ebuild

similarity index 59%
rename from app-doc/cppman/cppman-0.4.8-r1.ebuild
rename to app-doc/cppman/cppman-0.4.8-r2.ebuild
index 931aff72c2bd99e6ab47c0df51707adfa7ae4ba5..47193572aa467c0f34426db3d4bd5108e569afc3 100644 (file)
@@ -1,23 +1,24 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-PYTHON_COMPAT=( python3_6 )
-PYTHON_REQ_USE="sqlite,threads"
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite,threads(+)"
 
 DISTUTILS_SINGLE_IMPL=true
+DISTUTILS_USE_SETUPTOOLS=no
 
 inherit distutils-r1
 
 DESCRIPTION="C++ man pages for Linux, with source from cplusplus.com and cppreference.com"
 HOMEPAGE="https://github.com/aitjcize/cppman"
-LICENSE="GPL-3"
-
-SLOT="0"
 SRC_URI="https://github.com/aitjcize/cppman/archive/${PV}.tar.gz -> ${P}.tar.gz"
 
+LICENSE="GPL-3"
+SLOT="0"
 KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+IUSE="bash-completion zsh-completion"
 
 RDEPEND="
        sys-apps/groff
@@ -27,5 +28,12 @@ RDEPEND="
        ')
 "
 
-# `./setup install` already installs docs
-DOCS=()
+DOCS=( README.rst AUTHORS COPYING ChangeLog )
+
+src_prepare() {
+       sed -i '\:share/doc/cppman:d' setup.py
+       use bash-completion || sed -i '\:share/bash-completion/completions:d' setup.py
+       use zsh-completion || sed -i '\:share/zsh-completion/completions:d' setup.py
+
+       default
+}
index a124e60ffdd5cce6c609c6b945e3b85a503a2489..47193572aa467c0f34426db3d4bd5108e569afc3 100644 (file)
@@ -1,23 +1,24 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 PYTHON_COMPAT=( python3_{6,7,8} )
 PYTHON_REQ_USE="sqlite,threads(+)"
 
 DISTUTILS_SINGLE_IMPL=true
+DISTUTILS_USE_SETUPTOOLS=no
 
 inherit distutils-r1
 
 DESCRIPTION="C++ man pages for Linux, with source from cplusplus.com and cppreference.com"
 HOMEPAGE="https://github.com/aitjcize/cppman"
-LICENSE="GPL-3"
-
-SLOT="0"
 SRC_URI="https://github.com/aitjcize/cppman/archive/${PV}.tar.gz -> ${P}.tar.gz"
 
+LICENSE="GPL-3"
+SLOT="0"
 KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+IUSE="bash-completion zsh-completion"
 
 RDEPEND="
        sys-apps/groff
@@ -27,5 +28,12 @@ RDEPEND="
        ')
 "
 
-# `./setup install` already installs docs
-DOCS=()
+DOCS=( README.rst AUTHORS COPYING ChangeLog )
+
+src_prepare() {
+       sed -i '\:share/doc/cppman:d' setup.py
+       use bash-completion || sed -i '\:share/bash-completion/completions:d' setup.py
+       use zsh-completion || sed -i '\:share/zsh-completion/completions:d' setup.py
+
+       default
+}