net-libs/libmrss: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Sun, 9 Feb 2020 18:49:42 +0000 (19:49 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 9 Feb 2020 18:49:42 +0000 (19:49 +0100)
Package-Manager: Portage-2.3.88, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
net-libs/libmrss/libmrss-0.19.2.ebuild

index e57dc41abcabc03a7c6ff3fc5bb2a6553808eda7..f4ce0a9497b3d796440ee2ef225b42c0d0b7a76f 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="4"
+EAPI=7
 
 DESCRIPTION="A C-library for parsing and writing RSS 0.91/0.92/1.0/2.0 files or streams"
 HOMEPAGE="http://www.autistici.org/bakunin/libmrss/doc/"
@@ -10,27 +10,31 @@ SRC_URI="http://www.autistici.org/bakunin/${PN}/${P}.tar.gz"
 LICENSE="LGPL-2.1"
 SLOT="0"
 KEYWORDS="amd64 ~arm ~mips ppc x86"
-IUSE="doc examples static-libs"
+IUSE="doc examples"
 
-RDEPEND=">=net-libs/libnxml-0.18.0
+RDEPEND="
+       net-libs/libnxml
        net-misc/curl"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
        virtual/pkgconfig
        doc? ( app-doc/doxygen )"
 
 # TODO: php-bindings
 
 src_configure() {
-       econf \
-               $(use_enable static-libs static)
+       econf --disable-static
 }
 
 src_compile() {
-       emake
+       default
 
        if use doc; then
                ebegin "Creating documentation"
                doxygen doxy.conf || die "generating docs failed"
+               # clean out doxygen gunk
+               rm doc/html/*.{md5,map} || die
+               HTML_DOCS=( doc/html/. )
                eend 0
        fi
 }
@@ -38,14 +42,11 @@ src_compile() {
 src_install() {
        default
 
-       if use doc; then
-               dohtml doc/html/*
-       fi
-
        if use examples; then
-               insinto /usr/share/doc/${PF}/test
-               doins test/*.c
+               docinto test
+               dodoc test/*.c
        fi
 
-       find "${D}" -name '*.la' -exec rm -f {} +
+       # no static archives
+       find "${D}" -name '*.la' -delete || die
 }