sci-geosciences/osgearth: version bump to 2.7
authorJulian Ospald <hasufell@gentoo.org>
Sun, 16 Aug 2015 20:59:59 +0000 (22:59 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Sun, 16 Aug 2015 21:00:30 +0000 (23:00 +0200)
Fixes: 555938

sci-geosciences/osgearth/Manifest
sci-geosciences/osgearth/files/osgearth-2.7-linker.patch [new file with mode: 0644]
sci-geosciences/osgearth/osgearth-2.7.ebuild [new file with mode: 0644]

index 05f9801cc37f8fec65939cf5e618ec327159c0a8..d262160788c6b48362d9345e938cc37863f2a5ce 100644 (file)
@@ -1 +1,2 @@
 DIST osgearth-2.6.tar.gz 58605003 SHA256 965c93837520ab9538038843ff83ee1903548f8be191ee211e40abb0e6c1bb4a SHA512 3120547ef639d4c1ff0404358777317c8794a493a772dc7af11b8056fd3f799a5e16358c19970862d16f6ab98f78abb3ea25c3aa113df8a3df68d54818fb03bc WHIRLPOOL 6533e5a92ee973ff1d5bfb80ab3b051279bc65e85d00f0fb9027b6fe2be06efc5bd3907516c27e7e06b4c1cb03569650bf368b5d7728b848bc86ec9666607939
+DIST osgearth-2.7.tar.gz 61837911 SHA256 cf973b664aeb79f70e48f5cd02ba670069ec273d71fe541604ed5b328d956d83 SHA512 acc7235b2df4a226e6834f961006c35310183695925091dcdfb1339e89be8ef08773c8c62ca98eb708485e03a870dace65a27d0beb2aefc807f6e558243e4693 WHIRLPOOL 8d3afe46fbef7064235a85c78a7da160f982c7ce19d8310484feb31f0a2317de631796f471c1b547bb9a01de0958a8b28ba1d919a20be230ea4651c5fbd785a8
diff --git a/sci-geosciences/osgearth/files/osgearth-2.7-linker.patch b/sci-geosciences/osgearth/files/osgearth-2.7-linker.patch
new file mode 100644 (file)
index 0000000..74b5622
--- /dev/null
@@ -0,0 +1,52 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Aug 16 19:59:50 UTC 2015
+Subject: add missing library to linker
+
+--- a/src/applications/osgearth_package_qt/CMakeLists.txt
++++ b/src/applications/osgearth_package_qt/CMakeLists.txt
+@@ -59,6 +59,7 @@
+     ${QT_QTCORE_LIBRARY}
+     ${QT_QTGUI_LIBRARY}
+     ${QT_QTOPENGL_LIBRARY}
++      ${X11_LIBRARIES}
+ )
+ #### end var setup  ###
+--- a/src/applications/osgearth_qt/CMakeLists.txt
++++ b/src/applications/osgearth_qt/CMakeLists.txt
+@@ -38,6 +38,7 @@
+     ${QT_QTCORE_LIBRARY}
+     ${QT_QTGUI_LIBRARY}
+     ${QT_QTOPENGL_LIBRARY}
++      ${X11_LIBRARIES}
+ )
+ #### end var setup  ###
+--- a/src/applications/osgearth_demo/CMakeLists.txt
++++ b/src/applications/osgearth_demo/CMakeLists.txt
+@@ -7,6 +7,7 @@
+     QT5_WRAP_CPP( MOC_SRCS ${MOC_HDRS} OPTIONS "-f" )
+       SET(TARGET_ADDED_LIBRARIES
+         osgEarthQt
++              ${X11_LIBRARIES}
+     )
+ ELSE()
+     INCLUDE( ${QT_USE_FILE} )
+@@ -16,6 +17,7 @@
+         ${QT_QTCORE_LIBRARY}
+         ${QT_QTGUI_LIBRARY}
+         ${QT_QTOPENGL_LIBRARY}
++              ${X11_LIBRARIES}
+     )
+ ENDIF()
+--- a/src/applications/osgearth_qt_simple/CMakeLists.txt
++++ b/src/applications/osgearth_qt_simple/CMakeLists.txt
+@@ -34,6 +34,7 @@
+     ${QT_QTCORE_LIBRARY}
+     ${QT_QTGUI_LIBRARY}
+     ${QT_QTOPENGL_LIBRARY}
++      ${X11_LIBRARIES}
+ )
+ #### end var setup  ###
diff --git a/sci-geosciences/osgearth/osgearth-2.7.ebuild b/sci-geosciences/osgearth/osgearth-2.7.ebuild
new file mode 100644 (file)
index 0000000..13bb080
--- /dev/null
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Dynamic map generation toolkit for OpenSceneGraph"
+HOMEPAGE="http://osgearth.org/"
+SRC_URI="https://github.com/gwaldron/osgearth/archive/${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc qt5"
+
+RDEPEND="
+       dev-db/sqlite:3
+       >=dev-games/openscenegraph-3.2.1-r1[curl,qt5?]
+       dev-libs/protobuf
+       dev-libs/tinyxml
+       net-misc/curl
+       sci-libs/gdal
+       sci-libs/geos
+       sys-libs/zlib[minizip]
+       virtual/opengl
+       x11-libs/libX11
+       qt5? (
+               dev-qt/qtcore:5
+               dev-qt/qtgui:5
+               dev-qt/qtopengl:5
+       )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       doc? ( dev-python/sphinx )"
+
+S=${WORKDIR}/${PN}-${P}
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.6-cmake-options.patch
+       "${FILESDIR}"/${PN}-2.7-linker.patch
+)
+
+src_configure() {
+       # V8 disabled due to
+       # https://github.com/gwaldron/osgearth/issues/333
+       local mycmakeargs=(
+               -DWITH_EXTERNAL_TINYXML=ON
+               $(cmake-utils_use qt5 OSGEARTH_USE_QT)
+               -DUSE_V8=OFF
+               -DOSGEARTH_USE_JAVASCRIPTCORE=OFF
+       )
+
+       cmake-utils_src_configure
+}
+
+src_compile() {
+       cmake-utils_src_compile
+
+       if use doc ; then
+               emake -C "${S}"/docs man html info
+       fi
+}
+
+src_install() {
+       cmake-utils_src_install
+
+       if use doc ; then
+               dohtml -r "${S}"/docs/build/html/*
+               doman "${S}"/docs/build/man/*
+               doinfo "${S}"/docs/build/texinfo/*.info*
+       fi
+}