app-text/zathura-pdf-mupdf: fix build
authorMikle Kolyada <zlogene@gentoo.org>
Sun, 27 Oct 2019 10:52:08 +0000 (13:52 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sun, 27 Oct 2019 10:53:03 +0000 (13:53 +0300)
Closes: https://bugs.gentoo.org/693354
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
app-text/zathura-pdf-mupdf/files/0.3.5-compile-fix.patch [new file with mode: 0644]
app-text/zathura-pdf-mupdf/zathura-pdf-mupdf-0.3.5.ebuild

diff --git a/app-text/zathura-pdf-mupdf/files/0.3.5-compile-fix.patch b/app-text/zathura-pdf-mupdf/files/0.3.5-compile-fix.patch
new file mode 100644 (file)
index 0000000..e031db3
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/zathura-pdf-mupdf/search.c       2019-09-12 11:29:21.527194069 +0200
++++ b/zathura-pdf-mupdf/search.c       2019-09-12 11:30:11.648675352 +0200
+@@ -39,7 +39,7 @@
+     mupdf_page_extract_text(mupdf_document, mupdf_page);
+   }
+-  fz_quad* hit_bbox = fz_malloc_array(mupdf_page->ctx, N_SEARCH_RESULTS, fz_quad);
++  fz_quad* hit_bbox = fz_malloc_array(mupdf_page->ctx, N_SEARCH_RESULTS, sizeof(fz_quad));
+   int num_results = fz_search_stext_page(mupdf_page->ctx, mupdf_page->text,
+       text, hit_bbox, N_SEARCH_RESULTS);
index a8c73f86302b9a5953b9c6e9e25099e6b4d00c16..ec8c60cf28efd9044b216106650450d076f77baf 100644 (file)
@@ -35,5 +35,6 @@ BDEPEND="virtual/pkgconfig"
 
 src_prepare() {
        sed -i -e '/mupdfthird/d' meson.build || die "sed failed"
+       eapply "${FILESDIR}"/${PV}-compile-fix.patch
        default
 }