media-libs/mesa: Use virtual/libelf
authorMichał Górny <mgorny@gentoo.org>
Sat, 18 Jun 2016 17:46:18 +0000 (19:46 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 18 Jun 2016 18:08:17 +0000 (20:08 +0200)
media-libs/mesa/mesa-10.3.7-r1.ebuild
media-libs/mesa/mesa-11.0.6.ebuild
media-libs/mesa/mesa-11.0.9.ebuild
media-libs/mesa/mesa-11.1.3.ebuild
media-libs/mesa/mesa-11.1.4.ebuild
media-libs/mesa/mesa-11.2.1.ebuild
media-libs/mesa/mesa-11.2.2.ebuild
media-libs/mesa/mesa-7.10.3.ebuild
media-libs/mesa/mesa-9999.ebuild

index 9ca786846d92edbc5fb08cc248425ae3adbc6cf9..5f8375775a54532af48d7bb365534086881364d2 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -101,19 +101,10 @@ RDEPEND="
        >=x11-libs/libXxf86vm-1.1.3:=[${MULTILIB_USEDEP}]
        >=x11-libs/libxcb-1.9.3:=[${MULTILIB_USEDEP}]
        llvm? (
-               video_cards_radeonsi? ( || (
-                       >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                       >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                       ) )
-               video_cards_r600? ( || (
-                       >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                       >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                       ) )
+               video_cards_radeonsi? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
+               video_cards_r600? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
                !video_cards_r600? (
-                       video_cards_radeon? ( || (
-                               >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                               >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                               ) )
+                       video_cards_radeon? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
                )
                >=sys-devel/llvm-3.3-r3:=[${MULTILIB_USEDEP}]
                <sys-devel/llvm-3.6
index 5a849b1c26254015823c7a536ae97497eec04889..0ac12691886b78805091e23cf2625d51f25ae64a 100644 (file)
@@ -97,15 +97,9 @@ RDEPEND="
        >=x11-libs/libxcb-1.9.3:=[${MULTILIB_USEDEP}]
        x11-libs/libXfixes:=[${MULTILIB_USEDEP}]
        llvm? ( !kernel_FreeBSD? (
-               video_cards_radeonsi? ( || (
-                       >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                       >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                       ) )
+               video_cards_radeonsi? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
                !video_cards_r600? (
-                       video_cards_radeon? ( || (
-                               >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                               >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                               ) )
+                       video_cards_radeon? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
                ) )
                >=sys-devel/llvm-3.4.2:=[${MULTILIB_USEDEP}]
                <sys-devel/llvm-3.8
@@ -113,10 +107,7 @@ RDEPEND="
        opencl? (
                                app-eselect/eselect-opencl
                                dev-libs/libclc
-                               !kernel_FreeBSD? ( || (
-                                       >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                                       >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                               ) )
+                               !kernel_FreeBSD? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
                        )
        openmax? ( >=media-libs/libomxil-bellagio-0.9.3:=[${MULTILIB_USEDEP}] )
        vaapi? ( >=x11-libs/libva-0.35.0:=[${MULTILIB_USEDEP}] )
index f07599c623c4df381489eaa86634e53ef82f69ce..4e8394e743fd9247d9656b2dc11cee3c85c27d5b 100644 (file)
@@ -95,15 +95,9 @@ RDEPEND="
        >=x11-libs/libxcb-1.9.3:=[${MULTILIB_USEDEP}]
        x11-libs/libXfixes:=[${MULTILIB_USEDEP}]
        llvm? ( !kernel_FreeBSD? (
-               video_cards_radeonsi? ( || (
-                       >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                       >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                       ) )
+               video_cards_radeonsi? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
                !video_cards_r600? (
-                       video_cards_radeon? ( || (
-                               >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                               >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                               ) )
+                       video_cards_radeon? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
                ) )
                >=sys-devel/llvm-3.4.2:=[${MULTILIB_USEDEP}]
                <sys-devel/llvm-3.8
@@ -111,10 +105,7 @@ RDEPEND="
        opencl? (
                                app-eselect/eselect-opencl
                                dev-libs/libclc
-                               !kernel_FreeBSD? ( || (
-                                       >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                                       >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                               ) )
+                               !kernel_FreeBSD? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
                        )
        openmax? ( >=media-libs/libomxil-bellagio-0.9.3:=[${MULTILIB_USEDEP}] )
        vaapi? ( >=x11-libs/libva-0.35.0:=[${MULTILIB_USEDEP}] )
index c4a3cd77d4b537fbac765c1257b6af422204d017..93ba2c4451f319c259b627c1fd2749df54d14c1f 100644 (file)
@@ -95,15 +95,9 @@ RDEPEND="
        >=x11-libs/libxcb-1.9.3:=[${MULTILIB_USEDEP}]
        x11-libs/libXfixes:=[${MULTILIB_USEDEP}]
        llvm? ( !kernel_FreeBSD? (
-               video_cards_radeonsi? ( || (
-                       >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                       >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                       ) )
+               video_cards_radeonsi? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
                !video_cards_r600? (
-                       video_cards_radeon? ( || (
-                               >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                               >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                               ) )
+                       video_cards_radeon? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
                ) )
                >=sys-devel/llvm-3.4.2:=[${MULTILIB_USEDEP}]
                <sys-devel/llvm-3.8
@@ -111,10 +105,7 @@ RDEPEND="
        opencl? (
                                app-eselect/eselect-opencl
                                dev-libs/libclc
-                               !kernel_FreeBSD? ( || (
-                                       >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                                       >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                               ) )
+                               !kernel_FreeBSD? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
                        )
        openmax? ( >=media-libs/libomxil-bellagio-0.9.3:=[${MULTILIB_USEDEP}] )
        vaapi? ( >=x11-libs/libva-1.6.0:=[${MULTILIB_USEDEP}] )
index c4a3cd77d4b537fbac765c1257b6af422204d017..93ba2c4451f319c259b627c1fd2749df54d14c1f 100644 (file)
@@ -95,15 +95,9 @@ RDEPEND="
        >=x11-libs/libxcb-1.9.3:=[${MULTILIB_USEDEP}]
        x11-libs/libXfixes:=[${MULTILIB_USEDEP}]
        llvm? ( !kernel_FreeBSD? (
-               video_cards_radeonsi? ( || (
-                       >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                       >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                       ) )
+               video_cards_radeonsi? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
                !video_cards_r600? (
-                       video_cards_radeon? ( || (
-                               >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                               >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                               ) )
+                       video_cards_radeon? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
                ) )
                >=sys-devel/llvm-3.4.2:=[${MULTILIB_USEDEP}]
                <sys-devel/llvm-3.8
@@ -111,10 +105,7 @@ RDEPEND="
        opencl? (
                                app-eselect/eselect-opencl
                                dev-libs/libclc
-                               !kernel_FreeBSD? ( || (
-                                       >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                                       >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                               ) )
+                               !kernel_FreeBSD? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
                        )
        openmax? ( >=media-libs/libomxil-bellagio-0.9.3:=[${MULTILIB_USEDEP}] )
        vaapi? ( >=x11-libs/libva-1.6.0:=[${MULTILIB_USEDEP}] )
index 4bc07f8ebbacee214f45f162a05a870dc96ca2eb..570b78ee47ca33632b9eaae2e330455093ee47f3 100644 (file)
@@ -95,25 +95,16 @@ RDEPEND="
        >=x11-libs/libxcb-1.9.3:=[${MULTILIB_USEDEP}]
        x11-libs/libXfixes:=[${MULTILIB_USEDEP}]
        llvm? ( !kernel_FreeBSD? (
-               video_cards_radeonsi? ( || (
-                       >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                       >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                       ) )
+               video_cards_radeonsi? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
                !video_cards_r600? (
-                       video_cards_radeon? ( || (
-                               >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                               >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                               ) )
+                       video_cards_radeon? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
                ) )
                >=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
        )
        opencl? (
                                app-eselect/eselect-opencl
                                dev-libs/libclc
-                               !kernel_FreeBSD? ( || (
-                                       >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                                       >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                               ) )
+                               !kernel_FreeBSD? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
                        )
        openmax? ( >=media-libs/libomxil-bellagio-0.9.3:=[${MULTILIB_USEDEP}] )
        vaapi? ( >=x11-libs/libva-1.6.0:=[${MULTILIB_USEDEP}] )
index 4bc07f8ebbacee214f45f162a05a870dc96ca2eb..570b78ee47ca33632b9eaae2e330455093ee47f3 100644 (file)
@@ -95,25 +95,16 @@ RDEPEND="
        >=x11-libs/libxcb-1.9.3:=[${MULTILIB_USEDEP}]
        x11-libs/libXfixes:=[${MULTILIB_USEDEP}]
        llvm? ( !kernel_FreeBSD? (
-               video_cards_radeonsi? ( || (
-                       >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                       >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                       ) )
+               video_cards_radeonsi? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
                !video_cards_r600? (
-                       video_cards_radeon? ( || (
-                               >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                               >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                               ) )
+                       video_cards_radeon? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
                ) )
                >=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
        )
        opencl? (
                                app-eselect/eselect-opencl
                                dev-libs/libclc
-                               !kernel_FreeBSD? ( || (
-                                       >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                                       >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                               ) )
+                               !kernel_FreeBSD? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
                        )
        openmax? ( >=media-libs/libomxil-bellagio-0.9.3:=[${MULTILIB_USEDEP}] )
        vaapi? ( >=x11-libs/libva-1.6.0:=[${MULTILIB_USEDEP}] )
index 40c7513e4c710e2254f7f7fd5cd6a9bf3c850b77..c896c155550f1fdc22a3e261efb7de37ad976bd5 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
index bf3dbcc6831bb983d928f146800b2702f0803864..22068d2950594938bad81e82434a82652e5b0e2e 100644 (file)
@@ -95,25 +95,16 @@ RDEPEND="
        >=x11-libs/libxcb-1.9.3:=[${MULTILIB_USEDEP}]
        x11-libs/libXfixes:=[${MULTILIB_USEDEP}]
        llvm? ( !kernel_FreeBSD? (
-               video_cards_radeonsi? ( || (
-                       >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                       >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                       ) )
+               video_cards_radeonsi? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
                !video_cards_r600? (
-                       video_cards_radeon? ( || (
-                               >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                               >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                               ) )
+                       video_cards_radeon? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
                ) )
                >=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
        )
        opencl? (
                                app-eselect/eselect-opencl
                                dev-libs/libclc
-                               !kernel_FreeBSD? ( || (
-                                       >=dev-libs/elfutils-0.155-r1:=[${MULTILIB_USEDEP}]
-                                       >=dev-libs/libelf-0.8.13-r2:=[${MULTILIB_USEDEP}]
-                               ) )
+                               !kernel_FreeBSD? ( virtual/libelf:0=[${MULTILIB_USEDEP}] )
                        )
        openmax? ( >=media-libs/libomxil-bellagio-0.9.3:=[${MULTILIB_USEDEP}] )
        vaapi? ( >=x11-libs/libva-1.6.0:=[${MULTILIB_USEDEP}] )