dev-python/irc: bump to 16.3, add Python 3.6
authorLouis Sautier <sbraz@gentoo.org>
Sun, 24 Jun 2018 00:36:43 +0000 (02:36 +0200)
committerLouis Sautier <sbraz@gentoo.org>
Sun, 24 Jun 2018 00:36:43 +0000 (02:36 +0200)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-python/irc/Manifest
dev-python/irc/irc-16.3.ebuild [new file with mode: 0644]

index 8b4d763aa12b0f4b57dbf82caf53d4b917561706..3a36658a33554c86f2b46466e3a9efb607c3961f 100644 (file)
@@ -1 +1,2 @@
 DIST irc-15.0.6.tar.gz 81996 BLAKE2B b5d329b70404a92d4f69cc3fef2be374b0a1e98e04588b7f2f7f7c241dc3d72122f813b67e48522b7779dfdf90478db6ff10cda3c66b621f7c4a099142d533f0 SHA512 48240eb496a3c88310f02cf092b8e19e4aa8d8dc165a9a8a39c313490a69ecc29ac67db297436df5e86e7253e2481bd19bc0429ea9cc359089a5cd6179125c0f
+DIST irc-16.3.tar.gz 87067 BLAKE2B 61d8b9cc20390a3eb918e5593a167b28f37154ee05cb4d7a72f8901509d3345e8d6bee9c17b66aa6c71fad4608a9f98eb3848190f82eac7db6f2013227979c25 SHA512 84b5a56a441cdf22396c10b81c115cb2e297ac082785e9baf0bc73d655034be1ff3f553d44412f066ab4b74530faddb66a9cc2f511a332e87fe49af0b6e68e5b
diff --git a/dev-python/irc/irc-16.3.ebuild b/dev-python/irc/irc-16.3.ebuild
new file mode 100644 (file)
index 0000000..a588afd
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="IRC client framework written in Python"
+HOMEPAGE="https://github.com/jaraco/irc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="
+       >=dev-python/jaraco-functools-1.5[${PYTHON_USEDEP}]
+       >=dev-python/jaraco-itertools-1.8[${PYTHON_USEDEP}]
+       >=dev-python/tempora-1.6[${PYTHON_USEDEP}]
+       dev-python/jaraco-collections[${PYTHON_USEDEP}]
+       dev-python/jaraco-logging[${PYTHON_USEDEP}]
+       dev-python/jaraco-stream[${PYTHON_USEDEP}]
+       dev-python/jaraco-text[${PYTHON_USEDEP}]
+       dev-python/more-itertools[${PYTHON_USEDEP}]
+       dev-python/pytz[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+       test? (
+               ${RDEPEND}
+               dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
+               >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+       )
+       doc? (
+               >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
+               >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
+               dev-python/sphinx[${PYTHON_USEDEP}]
+       )
+"
+
+python_compile_all() {
+       if use doc; then
+               cd docs || die
+               sphinx-build . _build/html || die
+               HTML_DOCS=( docs/_build/html/. )
+       fi
+}
+
+python_test() {
+       # Override pytest options to skip flake8
+       py.test --override-ini="addopts=--doctest-modules" \
+               || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+       if use examples; then
+               docompress -x "/usr/share/doc/${PF}/scripts"
+               dodoc -r scripts
+       fi
+       distutils-r1_python_install_all
+}