dev-qt/qtwebkit: die if nothing is built
authorMichael Palimaka <kensington@gentoo.org>
Sat, 24 Jun 2017 02:28:02 +0000 (12:28 +1000)
committerMichael Palimaka <kensington@gentoo.org>
Sat, 24 Jun 2017 02:29:41 +0000 (12:29 +1000)
Gentoo-bug: 572056
Package-Manager: Portage-2.3.5, Repoman-2.3.2

dev-qt/qtwebkit/qtwebkit-5.7.1.ebuild

index a46c5c9563fdac06204a5cf96b837f8de891f6f3..8b06b94b88868cd03ed6400a8db69328dd37cae7 100644 (file)
@@ -107,3 +107,13 @@ src_prepare() {
 
        qt5-build_src_prepare
 }
+
+src_install() {
+       qt5-build_src_install
+
+       # bug 572056
+       if [[ ! -f ${D%/}${QT5_LIBDIR}/libQt5WebKit.so ]]; then
+               eerror "${CATEGORY}/${PF} could not build due to a broken ruby environment."
+               die 'Check "eselect ruby" and ensure you have a working ruby in your $PATH'
+       fi
+}