Version bump
authorMarkus Ullmann <jokey@gentoo.org>
Mon, 13 Nov 2006 23:18:01 +0000 (23:18 +0000)
committerMarkus Ullmann <jokey@gentoo.org>
Mon, 13 Nov 2006 23:18:01 +0000 (23:18 +0000)
Package-Manager: portage-2.1.2_rc1-r6

app-misc/g15daemon/ChangeLog
app-misc/g15daemon/files/digest-g15daemon-1.2.5 [new file with mode: 0644]
app-misc/g15daemon/files/g15daemon-1.2.5.confd [new file with mode: 0644]
app-misc/g15daemon/files/g15daemon-1.2.5.initd [new file with mode: 0644]
app-misc/g15daemon/g15daemon-1.2.5.ebuild [new file with mode: 0644]

index 58069be028c2f5106cb21e9b248fa3ae290e6204..f3890767c3cb4d84626357b0888128fdf4a841b6 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for app-misc/g15daemon
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/ChangeLog,v 1.5 2006/10/31 22:29:10 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/ChangeLog,v 1.6 2006/11/13 23:18:01 jokey Exp $
+
+*g15daemon-1.2.5 (13 Nov 2006)
+
+  13 Nov 2006; Markus Ullmann <jokey@gentoo.org>
+  -files/g15daemon-1.2.1.initd, +files/g15daemon-1.2.5.confd,
+  +files/g15daemon-1.2.5.initd, -g15daemon-1.2.1-r2.ebuild,
+  +g15daemon-1.2.5.ebuild:
+  Version bump
 
 *g15daemon-1.2.3 (31 Oct 2006)
 
diff --git a/app-misc/g15daemon/files/digest-g15daemon-1.2.5 b/app-misc/g15daemon/files/digest-g15daemon-1.2.5
new file mode 100644 (file)
index 0000000..19a3a47
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 59753037fc0e93b83ae67f8c38db4b82 g15daemon-1.2.5.tar.bz2 281845
+RMD160 fefe5c802469e67553e483626b28369a525fdd05 g15daemon-1.2.5.tar.bz2 281845
+SHA256 64b5046566d6116847826ecef6adcf9a87e279ea68bf1270d0ff314a3489b4e9 g15daemon-1.2.5.tar.bz2 281845
diff --git a/app-misc/g15daemon/files/g15daemon-1.2.5.confd b/app-misc/g15daemon/files/g15daemon-1.2.5.confd
new file mode 100644 (file)
index 0000000..e2b959e
--- /dev/null
@@ -0,0 +1,6 @@
+# /etc/conf.d/g15daemon: Configuration for the g15daemon
+
+# The L1 key is a , above the multimedia keys.  
+# Key to switch the client-screens. Default is the MR key,
+# Set to "yes" to use L1 key instead (black round key below the LCD).
+CLIENT_SWITCH_L1="no"
\ No newline at end of file
diff --git a/app-misc/g15daemon/files/g15daemon-1.2.5.initd b/app-misc/g15daemon/files/g15daemon-1.2.5.initd
new file mode 100644 (file)
index 0000000..b31ccb9
--- /dev/null
@@ -0,0 +1,35 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/files/g15daemon-1.2.5.initd,v 1.1 2006/11/13 23:18:01 jokey Exp $
+
+# Init script for g15daemon
+
+depend() {
+       after hotplug
+       after usb
+       after modules
+}
+
+start() {
+       ebegin "Starting g15daemon"
+
+       # Does the input device already exist?
+       if [[ -e /proc/modules && ! -e /dev/input/uinput ]] ; then
+               # We can load modules, but uinput device does not exist
+               einfo "Loading uinput module"
+               /sbin/modprobe uinput &> /dev/null
+       fi
+
+       local SWITCHKEY=""
+       [[ ${CLIENT_SWITCH_L1} = "yes" ]] && SWITCHKEY="--switch"
+       start-stop-daemon --start --background --pidfile /var/run/g15daemon.pid \
+               --exec /usr/sbin/g15daemon -- ${SWITCHKEY}
+       eend $? "Failed to start g15daemon."
+}
+
+stop() {
+       ebegin "Stopping g15daemon"
+       start-stop-daemon --stop --quiet --pidfile /var/run/g15daemon.pid
+       eend $?
+}
diff --git a/app-misc/g15daemon/g15daemon-1.2.5.ebuild b/app-misc/g15daemon/g15daemon-1.2.5.ebuild
new file mode 100644 (file)
index 0000000..308c42d
--- /dev/null
@@ -0,0 +1,130 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.2.5.ebuild,v 1.1 2006/11/13 23:18:01 jokey Exp $
+
+inherit eutils linux-info perl-module python multilib
+
+DESCRIPTION="G15daemon takes control of the G15 keyboard, through the linux kernel uinput device driver"
+HOMEPAGE="http://g15daemon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/g15daemon/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="perl python"
+
+DEPEND="dev-libs/libusb
+       dev-libs/libdaemon
+       >=dev-libs/libg15-1.1.0
+       perl? ( >=dev-perl/Inline-0.4 )
+       python? ( dev-lang/python )"
+
+RDEPEND="${DEPEND}
+       perl? ( dev-perl/GDGraph )"
+
+uinput_check() {
+       ebegin "Checking for uinput support"
+       linux_chkconfig_present INPUT_UINPUT
+       eend $?
+
+       if [[ $? -ne 0 ]] ; then
+               eerror "To use g15daemon, you need to compile your kernel with uinput support."
+               eerror "Please enable uinput support in your kernel config, found at:"
+               eerror
+               eerror "Device Drivers -> Input Device ... -> Miscellaneous devices -> User level driver support."
+               eerror
+               eerror "Once enabled, you should have the /dev/input/uinput device."
+               eerror "g15daemon will not work without the uinput device."
+               die "INPUT_UINPUT support not detected!"
+       fi
+}
+
+pkg_setup() {
+       linux-info_pkg_setup
+       uinput_check
+}
+
+src_unpack() {
+       unpack ${A}
+       if use perl; then
+               unpack "./${P}/lang-bindings/perl-G15Daemon-0.2.tar.gz"
+       fi
+       if use python; then
+               unpack "./${P}/lang-bindings/pyg15daemon-0.0.tar.bz2"
+       fi
+}
+
+src_compile() {
+       econf || die "configure failed"
+
+       emake || die "make failed"
+
+       if use perl; then
+               cd "${WORKDIR}/G15Daemon-0.2"
+               perl-module_src_compile
+       fi
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die "make install failed"
+
+       # remove odd docs installed my make
+       rm "${D}/usr/share/doc/${P}/"{LICENSE,README.usage}
+       gzip "${D}/usr/share/doc/${P}/"*
+
+       insinto /usr/share/g15daemon/contrib
+       doins contrib/xmodmaprc
+       doins contrib/xmodmap.sh
+       if use perl; then
+               doins contrib/testbindings.pl
+       fi
+
+       newconfd "${FILESDIR}/${P}.confd" ${PN}
+       newinitd "${FILESDIR}/${P}.initd" ${PN}
+
+       if use perl; then
+               einfo "Installing Perl Bindings (G15Daemon.pm)"
+               cd "${WORKDIR}/G15Daemon-0.2"
+               perl-module_src_install
+       fi
+
+       if use python; then
+               einfo "Installing Python Bindings (g15daemon.py)"
+               cd "${WORKDIR}/pyg15daemon"
+               python_version
+
+               insinto /usr/$(get_libdir)/python${PYVER}/site-packages/g15daemon
+               doins g15daemon.py
+               newdoc AUTHORS pyg15daemon_AUTHORS
+       fi
+}
+
+pkg_postinst() {
+       if use python; then
+               python_mod_optimize "${ROOT}/usr/lib/python*/site-packages/g15daemon"
+               einfo ""
+       fi
+
+       einfo "To use g15daemon, you need to add g15daemon to the default runlevel."
+       einfo "This can be done with:"
+       einfo "# /sbin/rc-update add g15daemon default"
+       einfo ""
+       einfo "To have all new keys working in X11,"
+       einfo "you'll need create a specific xmodmap in your home directory"
+       einfo "or edit the existant one."
+       einfo ""
+       einfo "create the xmodmap:"
+       einfo "cp /usr/share/g15daemon/contrib/xmodmaprc ~/.Xmodmap"
+       einfo ""
+       einfo "adding keycodes to an existing xmodmap:"
+       einfo "cat /usr/share/g15daemon/contrib/xmodmaprc >> ~/.Xmodmap"
+       einfo ""
+       einfo "NOTE: the daemon now supports to use the small round key"
+       einfo "instead of MR for switching LCD clients. see /etc/conf.d"
+}
+
+pkg_postrm() {
+       if use python; then
+               python_mod_cleanup "${ROOT}/usr/lib/python*/site-packages/g15daemon"
+       fi
+}
\ No newline at end of file