dev-vcs/git: Replace "libsecret" by "gnome-keyring" USE flag (bug #619484)
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 24 May 2017 08:48:43 +0000 (10:48 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 24 May 2017 08:49:00 +0000 (10:49 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-vcs/git/git-2.12.3.ebuild
dev-vcs/git/git-2.13.0.ebuild
dev-vcs/git/git-9999-r1.ebuild
dev-vcs/git/git-9999-r2.ebuild
dev-vcs/git/git-9999-r3.ebuild
dev-vcs/git/git-9999.ebuild
dev-vcs/git/metadata.xml

index e1c531411ace1f8660559708a30f8c7a1c731b0e..f58a551ff7bc6e99133241b3e89011a47f30cd69 100644 (file)
@@ -43,13 +43,13 @@ fi
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
 
 # Common to both DEPEND and RDEPEND
 CDEPEND="
+       gnome-keyring? ( app-crypt/libsecret )
        !libressl? ( dev-libs/openssl:0= )
        libressl? ( dev-libs/libressl:= )
-       libsecret? ( app-crypt/libsecret )
        sys-libs/zlib
        pcre? ( dev-libs/libpcre )
        perl? ( dev-lang/perl:=[-build(-)] )
@@ -359,7 +359,7 @@ src_compile() {
                cd "${S}"
        fi
 
-       if use libsecret ; then
+       if use gnome-keyring ; then
                cd "${S}"/contrib/credential/libsecret
                git_emake || die "emake git-credential-libsecret failed"
        fi
@@ -454,7 +454,7 @@ src_install() {
        doexe contrib/contacts/git-contacts
        dodoc contrib/contacts/git-contacts.txt
 
-       if use libsecret ; then
+       if use gnome-keyring ; then
                cd "${S}"/contrib/credential/libsecret
                dobin git-credential-libsecret
        fi
index 236e9870a18c4773c4c76d3ce60239ad592b3c65..8db4d054f323f0aee1556b6bada72ee17ea6c159 100644 (file)
@@ -43,13 +43,13 @@ fi
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
 
 # Common to both DEPEND and RDEPEND
 CDEPEND="
+       gnome-keyring? ( app-crypt/libsecret )
        !libressl? ( dev-libs/openssl:0= )
        libressl? ( dev-libs/libressl:= )
-       libsecret? ( app-crypt/libsecret )
        sys-libs/zlib
        pcre? ( dev-libs/libpcre )
        perl? ( dev-lang/perl:=[-build(-)] )
@@ -359,7 +359,7 @@ src_compile() {
                cd "${S}"
        fi
 
-       if use libsecret ; then
+       if use gnome-keyring ; then
                cd "${S}"/contrib/credential/libsecret
                git_emake || die "emake git-credential-libsecret failed"
        fi
@@ -454,7 +454,7 @@ src_install() {
        doexe contrib/contacts/git-contacts
        dodoc contrib/contacts/git-contacts.txt
 
-       if use libsecret ; then
+       if use gnome-keyring ; then
                cd "${S}"/contrib/credential/libsecret
                dobin git-credential-libsecret
        fi
index 581efda16671e71ffb00e5b604c4579eafdbfb75..73c3a63eff547fef60ab7069743f831f6b332267 100644 (file)
@@ -42,13 +42,13 @@ fi
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
 
 # Common to both DEPEND and RDEPEND
 CDEPEND="
+       gnome-keyring? ( app-crypt/libsecret )
        !libressl? ( dev-libs/openssl:0= )
        libressl? ( dev-libs/libressl:= )
-       libsecret? ( app-crypt/libsecret )
        sys-libs/zlib
        pcre? ( dev-libs/libpcre )
        perl? ( dev-lang/perl:=[-build(-)] )
@@ -358,7 +358,7 @@ src_compile() {
                cd "${S}"
        fi
 
-       if use libsecret ; then
+       if use gnome-keyring ; then
                cd "${S}"/contrib/credential/libsecret
                git_emake || die "emake git-credential-libsecret failed"
        fi
@@ -453,7 +453,7 @@ src_install() {
        doexe contrib/contacts/git-contacts
        dodoc contrib/contacts/git-contacts.txt
 
-       if use libsecret ; then
+       if use gnome-keyring ; then
                cd "${S}"/contrib/credential/libsecret
                dobin git-credential-libsecret
        fi
index f725b2c09472df3172cc4a350a4dfd15575e3f82..269086404b39af4da41d41834e0a7b0d40bc5d14 100644 (file)
@@ -42,13 +42,13 @@ fi
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
 
 # Common to both DEPEND and RDEPEND
 CDEPEND="
+       gnome-keyring? ( app-crypt/libsecret )
        !libressl? ( dev-libs/openssl:0= )
        libressl? ( dev-libs/libressl:= )
-       libsecret? ( app-crypt/libsecret )
        sys-libs/zlib
        pcre? ( dev-libs/libpcre )
        perl? ( dev-lang/perl:=[-build(-)] )
@@ -358,7 +358,7 @@ src_compile() {
                cd "${S}"
        fi
 
-       if use libsecret ; then
+       if use gnome-keyring ; then
                cd "${S}"/contrib/credential/libsecret
                git_emake || die "emake git-credential-libsecret failed"
        fi
@@ -453,7 +453,7 @@ src_install() {
        doexe contrib/contacts/git-contacts
        dodoc contrib/contacts/git-contacts.txt
 
-       if use libsecret ; then
+       if use gnome-keyring ; then
                cd "${S}"/contrib/credential/libsecret
                dobin git-credential-libsecret
        fi
index 29ed4c46363bcc3ebf2a7223d8826871467c9083..1d5145652541588a3396ae09fb2d77e825606864 100644 (file)
@@ -42,13 +42,13 @@ fi
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
 
 # Common to both DEPEND and RDEPEND
 CDEPEND="
+       gnome-keyring? ( app-crypt/libsecret )
        !libressl? ( dev-libs/openssl:0= )
        libressl? ( dev-libs/libressl:= )
-       libsecret? ( app-crypt/libsecret )
        sys-libs/zlib
        pcre? ( dev-libs/libpcre )
        perl? ( dev-lang/perl:=[-build(-)] )
@@ -358,7 +358,7 @@ src_compile() {
                cd "${S}"
        fi
 
-       if use libsecret ; then
+       if use gnome-keyring ; then
                cd "${S}"/contrib/credential/libsecret
                git_emake || die "emake git-credential-libsecret failed"
        fi
@@ -453,7 +453,7 @@ src_install() {
        doexe contrib/contacts/git-contacts
        dodoc contrib/contacts/git-contacts.txt
 
-       if use libsecret ; then
+       if use gnome-keyring ; then
                cd "${S}"/contrib/credential/libsecret
                dobin git-credential-libsecret
        fi
index c9be0f22ff2009580214e5d94e53ace4b9a2135c..1d2603cd7495ba029686048a13e3650518fe7ed7 100644 (file)
@@ -42,13 +42,13 @@ fi
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs +gpg highlight +iconv libressl libsecret mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs gnome-keyring +gpg highlight +iconv libressl mediawiki mediawiki-experimental +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
 
 # Common to both DEPEND and RDEPEND
 CDEPEND="
+       gnome-keyring? ( app-crypt/libsecret )
        !libressl? ( dev-libs/openssl:0= )
        libressl? ( dev-libs/libressl:= )
-       libsecret? ( app-crypt/libsecret )
        sys-libs/zlib
        pcre? ( dev-libs/libpcre )
        perl? ( dev-lang/perl:=[-build(-)] )
@@ -358,7 +358,7 @@ src_compile() {
                cd "${S}"
        fi
 
-       if use libsecret ; then
+       if use gnome-keyring ; then
                cd "${S}"/contrib/credential/libsecret
                git_emake || die "emake git-credential-libsecret failed"
        fi
@@ -453,7 +453,7 @@ src_install() {
        doexe contrib/contacts/git-contacts
        dodoc contrib/contacts/git-contacts.txt
 
-       if use libsecret ; then
+       if use gnome-keyring ; then
                cd "${S}"/contrib/credential/libsecret
                dobin git-credential-libsecret
        fi
index f7c6611562945aee6b1f926e86296e1beaf5088c..4a8fe9f2743b320ab13a14cd8762f5852a41c34f 100644 (file)
@@ -29,7 +29,6 @@
     <flag name="curl">Support fetching and pushing (requires webdav too) over http:// and https:// protocols</flag>
     <flag name="gpg">Pull in gnupg for signing -- without gnupg, attempts at signing will fail at runtime!</flag>
     <flag name="highlight">GitWeb support for app-text/highlight</flag>
-    <flag name="libsecret">Enable libsecret support to store login credentials</flag>
     <flag name="mediawiki">Support pulling and pushing from MediaWiki</flag>
     <flag name="mediawiki-experimental">Add experimental patches for improved MediaWiki support</flag>
     <flag name="ppcsha1">Make use of a bundled routine that is optimized for the PPC arch</flag>