dev-python/iminuit: bump to 1.3.8
authorAndrey Grozin <grozin@gentoo.org>
Tue, 17 Mar 2020 15:11:23 +0000 (22:11 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Tue, 17 Mar 2020 15:11:23 +0000 (22:11 +0700)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
dev-python/iminuit/Manifest
dev-python/iminuit/iminuit-1.3.8.ebuild [new file with mode: 0644]

index 8fa6ef6633c8f7bc1d52cc5f12af29689e4ef5bc..1723f9ed7d254e756a8d815637add02b6885a3c6 100644 (file)
@@ -1,2 +1,3 @@
 DIST iminuit-1.2.tar.gz 931630 BLAKE2B 77719b00ba2356ad51577308a470d17e22ac898fe49fe15a31cdf1a4e8e9e4ca023e7d255e87f62f43d895c6ee18892f46e8a5ca7a70ef3d6335e28bdd369b64 SHA512 b9836abf57a3c33bfdf044655e3b8f465cf5252a10a50c17a70f382b8283754095f083e523060fd6d33c7e4c345b8c9923255408120e8bcfcedf1eee8de2dbca
 DIST iminuit-1.3.3.tar.gz 498456 BLAKE2B 3e10ed6d9166c05810e1ec8a2efda3743a3fcf01a738c08312f178dfa9d463792f77fb7e9f6ed6b07c0f98d618d168b32b8269a0542b3ec066f4696710282cff SHA512 8da6c6383bdb24caba0b346f4e0ce1ea027b460dd8ff8f1dd349f678ef55e4d9a693eca143045eea632a5cf7b5f2c10627b41bad208aa128b717777557b2c306
+DIST iminuit-1.3.8.tar.gz 496459 BLAKE2B 71920535b48ea135b34c9f55b0ac0aecc290ff68dd9a27e549ad643caabb4722899ed8eb3e413850ceb965910c39452c59c3ff4cb93416e4f945534f9a518071 SHA512 4c0069389a5e53b6e082ef82e56226427fdfd66c51b6c5bc488ebb2b113fd98ab6494d26c94f97255eec775e6441bda5c506b402ad13ad8698c361742e8cbc60
diff --git a/dev-python/iminuit/iminuit-1.3.8.ebuild b/dev-python/iminuit/iminuit-1.3.8.ebuild
new file mode 100644 (file)
index 0000000..7297c94
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Minuit numerical function minimization in Python"
+HOMEPAGE="https://github.com/iminuit/iminuit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SLOT="0"
+LICENSE="MIT LGPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+# removed until ipython and matplotlib get python3_8
+IUSE=""
+#IUSE="test"
+#RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       dev-python/cython[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+#      test? (
+#        dev-python/ipython[${PYTHON_USEDEP}]
+#        dev-python/matplotlib[${PYTHON_USEDEP}]
+#        dev-python/pytest[${PYTHON_USEDEP}] )
+
+#python_test() {
+#      virtx esetup.py test
+#}