dev-ruby/hoe: cleanup
authorHans de Graaff <graaff@gentoo.org>
Mon, 27 Apr 2020 09:15:36 +0000 (11:15 +0200)
committerHans de Graaff <graaff@gentoo.org>
Tue, 28 Apr 2020 04:39:55 +0000 (06:39 +0200)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/hoe/Manifest
dev-ruby/hoe/hoe-3.18.1.ebuild [deleted file]
dev-ruby/hoe/hoe-3.19.0.ebuild [deleted file]
dev-ruby/hoe/hoe-3.20.0.ebuild [deleted file]

index 0652563f7d442156d03b483d1f042b12b6bc3129..0b6b0575bb02b70ec27899b819f3b809289d0c5d 100644 (file)
@@ -1,5 +1,2 @@
 DIST hoe-3.16.0.gem 188416 BLAKE2B 48383c46512a359a269ca3475ec701b1443e0ef71b31d1ca1604de391ed4df6b0ad27dd1c5f6ed04751047d211f2c6299245361cf131e2418f224324ac9934c3 SHA512 66cefb5a24906e19bbf0c82c8539d6d101b84d0dc1d3ce1910e4117357639489968271e76e86bd3c432b9ef7e3b24a78294c06210cbef280860f7dac18100606
-DIST hoe-3.18.1.gem 190976 BLAKE2B 1b99125fddc42253918d2b9412401c0ed54a12006347b400050ecda17a1ce4491bf0419bc6ea28b68d5e1d77990973171c822862d93ee2cdc00a078f4e137587 SHA512 c281cdb2e89272ea84e54cd36d0cdec77cf6dd51f745c0aa99593586781e5182129f967086f008c33b38d25d7a3aacd2fa1899752e63f725d5ecf5fd5c04682c
-DIST hoe-3.19.0.gem 191488 BLAKE2B 186b2ad78f4f7181fa1120a2e1736ee630e16c73c2c748333ce5aab745bec433b1b11019e0a96fbef65c1d5f7039925e9fa161fd54a83ebbaee8e25299be3565 SHA512 1bdc77f78f0b1a7e0832107d40679928d8f0edc0a1deeb0e63c7f8e2f7601b5cbe0bc6c19e6f8b2f26459710a31538f8efc433ef5e930058d852e945c0b280b0
-DIST hoe-3.20.0.gem 192000 BLAKE2B 1eab1396c2dce2001b104e0587a0616913b0d0babb3d5e3d28214d04a57f70b056ba2c50843326676eec9723f9bd82625bcdf7af00eb8f3d5ef3dedc150eef9c SHA512 38f000ab396453866eb87b31a90a8714ec5bd0d8615deee9e4ab8d4fae728ffdd38f836f6cd78f63e60998705d7f2e579e2d2bd3d8ca11421785868370e20e20
 DIST hoe-3.21.0.gem 193024 BLAKE2B 2ff65edc6e0aebc93ebc8f3e628261ac3fabec4034b8e7b1bb3c38ab45c8b4641267a8c46c851ad69425c08782553c628574ae0a1417257cf64ba05a86de08f3 SHA512 39da93520bdb4efcbc58af58562ff8abbdecf45f92071ddb31f68ac799eb6f704431cea3d699aa039ba3a5217dc9b0f2d87f8b553d62860c34cb63803b625754
diff --git a/dev-ruby/hoe/hoe-3.18.1.ebuild b/dev-ruby/hoe/hoe-3.18.1.ebuild
deleted file mode 100644 (file)
index 18a0387..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="History.rdoc Manifest.txt README.rdoc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="template"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Hoe extends rake to provide full project automation"
-HOMEPAGE="https://www.zenspider.com/projects/hoe.html"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc"
-
-ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.9:5 )"
-
-ruby_add_rdepend ">=dev-ruby/rake-0.8.7 <dev-ruby/rake-13.0"
-
-all_ruby_prepare() {
-       # Skip isolation
-       sed -i -e '/isolate/ s:^:#:' Rakefile || die
-
-       # Skip test depending on specifics of gem command name
-       sed -i -e '/test_nosudo/,/^  end/ s:^:#:' test/test_hoe.rb || die
-
-       # Avoid test with random sort order
-       sed -i -e '/test_possibly_better/askip "ordering issues"' test/test_hoe.rb || die
-}
-
-all_ruby_compile() {
-       all_fakegem_compile
-
-       if use doc; then
-               rdoc --title "seattlerb's hoe-${PV} Documentation" -o doc --main README.txt lib History.txt Manifest.txt README.txt || die
-               rm -f doc/js/*.gz || die
-       fi
-}
diff --git a/dev-ruby/hoe/hoe-3.19.0.ebuild b/dev-ruby/hoe/hoe-3.19.0.ebuild
deleted file mode 100644 (file)
index 18a0387..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="History.rdoc Manifest.txt README.rdoc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="template"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Hoe extends rake to provide full project automation"
-HOMEPAGE="https://www.zenspider.com/projects/hoe.html"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc"
-
-ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.9:5 )"
-
-ruby_add_rdepend ">=dev-ruby/rake-0.8.7 <dev-ruby/rake-13.0"
-
-all_ruby_prepare() {
-       # Skip isolation
-       sed -i -e '/isolate/ s:^:#:' Rakefile || die
-
-       # Skip test depending on specifics of gem command name
-       sed -i -e '/test_nosudo/,/^  end/ s:^:#:' test/test_hoe.rb || die
-
-       # Avoid test with random sort order
-       sed -i -e '/test_possibly_better/askip "ordering issues"' test/test_hoe.rb || die
-}
-
-all_ruby_compile() {
-       all_fakegem_compile
-
-       if use doc; then
-               rdoc --title "seattlerb's hoe-${PV} Documentation" -o doc --main README.txt lib History.txt Manifest.txt README.txt || die
-               rm -f doc/js/*.gz || die
-       fi
-}
diff --git a/dev-ruby/hoe/hoe-3.20.0.ebuild b/dev-ruby/hoe/hoe-3.20.0.ebuild
deleted file mode 100644 (file)
index 849e153..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="History.rdoc Manifest.txt README.rdoc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="template"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Hoe extends rake to provide full project automation"
-HOMEPAGE="https://www.zenspider.com/projects/hoe.html"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc"
-
-ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.9:5 )"
-
-ruby_add_rdepend ">=dev-ruby/rake-0.8.7 <dev-ruby/rake-15.0"
-
-all_ruby_prepare() {
-       # Skip isolation
-       sed -i -e '/isolate/ s:^:#:' Rakefile || die
-
-       # Skip test depending on specifics of gem command name
-       sed -i -e '/test_nosudo/,/^  end/ s:^:#:' test/test_hoe.rb || die
-
-       # Avoid test with random sort order
-       sed -i -e '/test_possibly_better/askip "ordering issues"' test/test_hoe.rb || die
-}
-
-all_ruby_compile() {
-       all_fakegem_compile
-
-       if use doc; then
-               rdoc --title "seattlerb's hoe-${PV} Documentation" -o doc --main README.txt lib History.txt Manifest.txt README.txt || die
-               rm -f doc/js/*.gz || die
-       fi
-}