dev-python/pycson: initial import
authorAndrey Grozin <grozin@gentoo.org>
Sun, 11 Nov 2018 11:56:10 +0000 (18:56 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Sun, 11 Nov 2018 11:56:10 +0000 (18:56 +0700)
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Package-Manager: Portage-2.3.41, Repoman-2.3.9

dev-python/pycson/Manifest [new file with mode: 0644]
dev-python/pycson/metadata.xml [new file with mode: 0644]
dev-python/pycson/pycson-0.7.ebuild [new file with mode: 0644]

diff --git a/dev-python/pycson/Manifest b/dev-python/pycson/Manifest
new file mode 100644 (file)
index 0000000..e397377
--- /dev/null
@@ -0,0 +1 @@
+DIST pycson-0.7.tar.gz 9970 BLAKE2B 4ea59d558cd668b0ee074d22f19509056f5b39ee35289fb4de9123ff39472121a2cf57cba59888c43275c3a8ead2fdee2355b654aecad4fedbf796b478c02c06 SHA512 e8a48afbdd48d4250891d449c80f99bfc668e128a2784c1b951acd7e217cb66f6e527a7d417be3c5362930d426fc189cd3d0a7f4b2e41df351d2347f44d0e206
diff --git a/dev-python/pycson/metadata.xml b/dev-python/pycson/metadata.xml
new file mode 100644 (file)
index 0000000..5e324f5
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>grozin@gentoo.org</email>
+    <name>Andrey Grozin</name>
+  </maintainer>
+  <upstream>
+    <remote-id type="pypi">cson</remote-id>
+    <remote-id type="github">avakar/pycson</remote-id>
+  </upstream>
+</pkgmetadata>
diff --git a/dev-python/pycson/pycson-0.7.ebuild b/dev-python/pycson/pycson-0.7.ebuild
new file mode 100644 (file)
index 0000000..9c5fe89
--- /dev/null
@@ -0,0 +1,13 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+DESCRIPTION="A python parser for the Coffeescript Object Notation (CSON)"
+HOMEPAGE="https://github.com/avakar/pycson/"
+SRC_URI="https://github.com/avakar/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/speg"