games-action/battalion: Remove old
authorDavid Seifert <soap@gentoo.org>
Sun, 19 Nov 2017 15:50:33 +0000 (16:50 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 19 Nov 2017 15:51:21 +0000 (16:51 +0100)
Package-Manager: Portage-2.3.14, Repoman-2.3.6

games-action/battalion/battalion-1.4b.ebuild [deleted file]

diff --git a/games-action/battalion/battalion-1.4b.ebuild b/games-action/battalion/battalion-1.4b.ebuild
deleted file mode 100644 (file)
index 0ded9a0..0000000
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils games
-
-DESCRIPTION="Be a rampaging monster and destroy the city"
-HOMEPAGE="http://evlweb.eecs.uic.edu/aej/AndyBattalion.html"
-SRC_URI="http://evlweb.eecs.uic.edu/aej/BATTALION/${PN}${PV}.tar.bz2"
-
-LICENSE="battalion HPND"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-
-DEPEND="virtual/opengl
-       virtual/glu
-       x11-libs/libX11"
-RDEPEND=${DEPEND}
-
-S=${WORKDIR}/${PN}${PV}
-
-src_prepare() {
-       epatch "${FILESDIR}"/${P}-warning.patch
-       # Modify data paths
-       sed -i \
-               -e "s:SOUNDS/:${GAMES_DATADIR}/${PN}/SOUNDS/:" \
-               -e "s:MUSIC/:${GAMES_DATADIR}/${PN}/MUSIC/:" \
-               audio.c || die
-       sed -i \
-               -e "s:DATA/:${GAMES_DATADIR}/${PN}/DATA/:" \
-               -e "s:/usr/tmp:${GAMES_STATEDIR}:" \
-               battalion.c || die
-       sed -i \
-               -e "s:TEXTURES/:${GAMES_DATADIR}/${PN}/TEXTURES/:" \
-               graphics.c || die
-
-       # Modify Makefile and add CFLAGS
-       sed -i \
-               -e "s:-O2:${CFLAGS}:" \
-               -e "/^CC/d" \
-               Makefile || die
-       # Only .raw sound files are used on Linux. The .au files are not needed.
-       rm -f {SOUNDS,MUSIC}/*.au
-}
-
-src_compile() {
-       emake LIBFLAGS="${LDFLAGS}"
-}
-
-src_install() {
-       dogamesbin battalion
-       insinto "${GAMES_DATADIR}"/${PN}
-       doins -r DATA MUSIC SOUNDS TEXTURES
-       dodoc README
-
-       dodir "${GAMES_STATEDIR}"
-       touch "${D}${GAMES_STATEDIR}"/battalion_hiscore
-       fperms 660 "${GAMES_STATEDIR}"/battalion_hiscore
-
-       prepgamesdirs
-}
-
-pkg_postinst() {
-       games_pkg_postinst
-       elog "Sound and music are not enabled by default."
-       elog "Use the S and M keys to enable them in-game, or start the game with"
-       elog "the -s and -m switches: battalion -s -m"
-}