app-text/wscr: EAPI=7
authorJeroen Roovers <jer@gentoo.org>
Sun, 5 Jan 2020 16:06:53 +0000 (17:06 +0100)
committerJeroen Roovers <jer@gentoo.org>
Sun, 5 Jan 2020 16:28:56 +0000 (17:28 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
app-text/wscr/wscr-1.2-r2.ebuild [new file with mode: 0644]

diff --git a/app-text/wscr/wscr-1.2-r2.ebuild b/app-text/wscr/wscr-1.2-r2.ebuild
new file mode 100644 (file)
index 0000000..3a34f41
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="A Lightweight and Fast Anagram Solver"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI="https://dev.gentoo.org/~jer/${P}.tar.gz"
+LICENSE="public-domain"
+SLOT="0"
+
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+RDEPEND="sys-apps/miscfiles"
+
+src_prepare() {
+       default
+       sed -i 's#"/usr/dict/words";#"/usr/share/dict/words";#' wscr.h || die
+}
+
+src_compile() {
+       emake CC="$(tc-getCC)" FLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+       dobin wscr
+       doman wscr.6
+       dodoc README
+}