dev-perl/Net-LibIDN: Add subslot operator version re bug #655874
authorKent Fredric <kentnl@gentoo.org>
Wed, 17 Jul 2019 05:38:24 +0000 (17:38 +1200)
committerKent Fredric <kentnl@gentoo.org>
Wed, 17 Jul 2019 05:38:39 +0000 (17:38 +1200)
- Convert to EAPI6
- Add subslot operator for libidn:0=

Bug: https://bugs.gentoo.org/655874
Bug: https://github.com/gentoo/gentoo/pull/8908
Package-Manager: Portage-2.3.66, Repoman-2.3.16
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/Net-LibIDN/Net-LibIDN-0.120.0-r2.ebuild [new file with mode: 0644]

diff --git a/dev-perl/Net-LibIDN/Net-LibIDN-0.120.0-r2.ebuild b/dev-perl/Net-LibIDN/Net-LibIDN-0.120.0-r2.ebuild
new file mode 100644 (file)
index 0000000..99370c9
--- /dev/null
@@ -0,0 +1,17 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=THOR
+DIST_VERSION=0.12
+inherit perl-module
+
+DESCRIPTION="Perl bindings for GNU Libidn"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="net-dns/libidn:0="
+DEPEND="${RDEPEND}"