Handle tree conflicts in svn status output, new in subversion 1.6. Thanks to
authorZac Medico <zmedico@gentoo.org>
Mon, 29 Dec 2008 23:01:50 +0000 (23:01 -0000)
committerZac Medico <zmedico@gentoo.org>
Mon, 29 Dec 2008 23:01:50 +0000 (23:01 -0000)
Arfrever Frehtes Taifersar Arahesis for reporting.

svn path=/main/trunk/; revision=12368

bin/repoman

index a2d7d8bc2ee1c52270108dc42a90d2a0500c9977..84a023561bf6908cea5d069d54714e9a288bdb08 100755 (executable)
@@ -910,6 +910,9 @@ for x in scanlist:
                                if vcs == "svn":
                                        if l[:1] == "?":
                                                continue
+                                       if l[:7] == '      >':
+                                               # tree conflict, new in subversion 1.6
+                                               continue
                                        l = l.split()[-1]
                                        if l[-7:] == ".ebuild":
                                                eadded.append(os.path.basename(l[:-7]))