games-action/violetland: Drop old 0.4.3-r1
authorJames Le Cuirot <chewi@gentoo.org>
Sun, 10 Nov 2019 12:23:11 +0000 (12:23 +0000)
committerJames Le Cuirot <chewi@gentoo.org>
Sun, 10 Nov 2019 12:23:51 +0000 (12:23 +0000)
Package-Manager: Portage-2.3.79, Repoman-2.3.17
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-action/violetland/Manifest
games-action/violetland/files/violetland-0.4.3-boost150.patch [deleted file]
games-action/violetland/violetland-0.4.3-r1.ebuild [deleted file]

index 36b692b15f7ee273f64efad9b9f2ebb9b334cc10..cb15d8dc99026c03d845e0998351b2f320b76ad9 100644 (file)
@@ -1,2 +1 @@
-DIST violetland-0.4.3.tar.gz 9257919 BLAKE2B 255c9c13a49db576a37dbd4aa863306f0778f9528173426b26934a674dd0145574ff96242577feff8a4566571eebd97d0cb7a1d8a9718ac84fcd6c4492230fd5 SHA512 678e1aea42c9358794c6b8b83bdd113baf26e16db4cb815c756cb6c1d268b8210d18a47d1a98a019556633b4db62cd8cf7fc6a1e1ec3b7e3647a9d8353020fae
 DIST violetland-0.5-source-with-dependencies.tar.gz 11495885 BLAKE2B 33c3e8a8955ddc416c66c761681dce337ecccdb52ae7be3777124f4854c325436296ea5614100527a3e5be6c4d3a3cf2dffb2336037d5e904b50e2ae843d0fc4 SHA512 9b00fa600332c956c49bc5906f373c0dfff08a13320617014942ac4dbc199de8f84bef87ed218b38812ae3c53622e9148aa4463c4ea219056360bff1c73b7f88
diff --git a/games-action/violetland/files/violetland-0.4.3-boost150.patch b/games-action/violetland/files/violetland-0.4.3-boost150.patch
deleted file mode 100644 (file)
index 5ddd5e8..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
---- a/CMakeLists.txt   2012-11-05 15:19:11.501044743 +0100
-+++ b/CMakeLists.txt   2012-11-05 15:19:25.415250207 +0100
-@@ -8,7 +8,6 @@
- find_package(SDL_mixer REQUIRED)\r
- find_package(OpenGL REQUIRED)\r
- find_package(Boost COMPONENTS filesystem system REQUIRED)\r
--add_definitions(-DBOOST_FILESYSTEM_VERSION=2)\r
\r
- if(${MINGW})\r
-       set(INTL_LIBRARY intl)\r
---- a/src/system/utility/FileUtility.cpp       2012-11-05 21:26:07.865488297 +0100
-+++ b/src/system/utility/FileUtility.cpp       2012-11-05 21:30:44.881208230 +0100
-@@ -20,7 +20,7 @@
\r
-       while (dir_it != boost::filesystem::directory_iterator()) {\r
-               if (boost::filesystem::is_regular_file(*dir_it))\r
--                      files.push_back(dir_it->filename());\r
-+                      files.push_back(dir_it->path().filename().string());\r
-               ++dir_it;\r
-       }\r
-       return files;\r
-@@ -32,8 +32,8 @@
\r
-       while (dir_it != boost::filesystem::directory_iterator()) {\r
-               if (boost::filesystem::is_directory(*dir_it))\r
--                      if (dir_it->path().filename()[0] != '.')\r
--                              subDirs.push_back(dir_it->path().filename());\r
-+                      if (dir_it->path().filename().string()[0] != '.')\r
-+                              subDirs.push_back(dir_it->path().filename().string());\r
-               ++dir_it;\r
-       }\r
-       return subDirs;\r
-@@ -45,7 +45,7 @@
\r
-       while (dir_it != boost::filesystem::directory_iterator()) {\r
-               if (boost::filesystem::is_directory(*dir_it))\r
--                      if (dir_it->path().filename()[0] != '.')\r
-+                      if (dir_it->path().filename().string()[0] != '.')\r
-                               ++count;\r
-               ++dir_it;\r
-       }\r
diff --git a/games-action/violetland/violetland-0.4.3-r1.ebuild b/games-action/violetland/violetland-0.4.3-r1.ebuild
deleted file mode 100644 (file)
index ce501bb..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils desktop
-
-DESCRIPTION="Help a girl named Violet in the struggle with hordes of monsters"
-HOMEPAGE="https://violetland.github.io/"
-SRC_URI="https://github.com/ooxi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3 CC-BY-SA-3.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
-       dev-libs/boost:=[threads(+)]
-       media-libs/libsdl[sound,video]
-       media-libs/sdl-image[png]
-       media-libs/sdl-mixer[vorbis]
-       media-libs/sdl-ttf
-       virtual/glu
-       virtual/opengl"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}"/${P}-boost150.patch )
-
-src_prepare() {
-       cmake-utils_src_prepare
-
-       sed -i \
-               -e "/README_EN.TXT/d" \
-               -e "/README_RU.TXT/d" \
-               CMakeLists.txt || die "sed failed"
-       rm README_RU.TXT || die
-}
-
-src_configure() {
-       local mycmakeargs=(
-               -DDATA_INSTALL_DIR=share/${PN}
-       )
-       cmake-utils_src_configure
-}
-
-src_install() {
-       cmake-utils_src_install
-
-       newicon icon-light.png ${PN}.png
-       make_desktop_entry ${PN} VioletLand
-}